Page 1 of 1

Milter server is not running.

Posted: Fri Jan 23, 2015 2:18 am
by manspan

Dear sirs,


I have installed ZImbra Collaboration Server (Version 8.5.1_GA_3056.FOSS) on Ubuntu 14.04.1 LTS.


I’m trying to enable milter server but I haven't managed to do it:


When I execute “zmmilterctl start” I get “Starting milter server...done.”
When I execute “zmmilterctl status” I get “Milter server is not running.”
and on milter.log I get “Unable to start milter server com.zimbra.common.service.ServiceException: system failure: Could not bind to port=7026 bindaddr= ssl=false useChannels=true”


Could you please help me?


Manolis


Milter server is not running.

Posted: Fri Jan 23, 2015 4:58 am
by jorgedlcruz
Hi manspan,

Do you have other service running in port 7026? Could you please check it?

Did you change the postfix configuration by hand in any point?



I've just launch the command ion my Zimbra 8.6 and started without any issue.



Best regards

Milter server is not running.

Posted: Fri Jan 23, 2015 6:50 am
by manspan

Thank you Jorge for your reply.


I have followed your suggestion and checked if port 7026 is in use: netstat -anltp|grep :7026
and i got: tcp        0      0 0.0.0.0:7026            0.0.0.0:*               LISTEN      31481/java


I've changed port number: zmprov ms my_mail_server_name  zimbraMilterBindPort 7080
and now milter server is up and running, but there is something strange go on:


From Zimbra Administration Console milter server seems to run in two different ports:


Home-->Configure-->Global settings-->MTA-->Milter server bind port: 7026


Home-->Configure-->Server-->my_server_name-->MTA-->Milter server bind port: 7080


Any ideas?


 


Milter server is not running.

Posted: Mon Jan 26, 2015 9:05 am
by jorgedlcruz
Hi manspan,

I think that your milter server was running already, when I run the command zmmilterctl start the port 7026 starts to listen, if I turn of the Milter server, the port is shutdown, so when you had the port listening in 7026 means that you had the Milter enabled.



Let me check in 8.5.1 like you.



Best regards

Milter server is not running.

Posted: Mon Jan 26, 2015 6:23 pm
by jorgedlcruz

Hi manspan,


I've installed a fresh 8.5.1 in Ubuntu 14.04, and then activate the Milter server, and everything worked well. So can you please change the port in Zimbra for the default one in Milter, and try to do zmcontrol restart?


Let us know, here my log:


root@zimbra851:/home/oper# netstat -anltp|grep :7026
root@zimbra851:/home/oper# su - zimbra
zimbra@zimbra851:~$ zmmilterctl start
Starting milter server...done.
zimbra@zimbra851:~$ zmmilterctl status
Milter server is running.
zimbra@zimbra851:~$ exit
logout
root@zimbra851:/home/oper# netstat -anltp|grep :7026
tcp 0 0 0.0.0.0:7026 0.0.0.0:* LISTEN 105161/java
root@zimbra851:/home/oper#

Best regards


Re: Milter server is not running.

Posted: Wed May 22, 2019 5:21 pm
by fingotesto
Muchas gracias, yo tenia el problema de que no iniciaba el servicio, con el cambio de puerto por fin pude inicializar sin ningĂșn problema