Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
cgonsalves
Posts: 8
Joined: Mon Nov 03, 2014 9:53 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby cgonsalves » Wed Nov 04, 2015 1:11 am

Hello,


Zimbra Release 8.0.4.GA.5737.UBUNTU12.64 UBUNTU12_64 FOSS edition.


Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how can I disable this and make sure that all outgoing mails internal and internal must be sent after authentication.



Thanks,


Clifford



eranga
Posts: 22
Joined: Sat Sep 13, 2014 3:20 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby eranga » Wed Nov 04, 2015 2:00 am

remove your LAN ip range from the trusted networks. only keep 127.0.0.1 and server IP's as trusted IP's
cgonsalves
Posts: 8
Joined: Mon Nov 03, 2014 9:53 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby cgonsalves » Wed Nov 04, 2015 6:18 am

Well the server is not on our LAN its in the data center (different network), but internal emails do not require authentication.
How can I disable this and make sure that all outgoing mails internal and internal must be sent after authentication.

Clifford

eranga
Posts: 22
Joined: Sat Sep 13, 2014 3:20 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby eranga » Wed Nov 04, 2015 9:22 am

In the admin console go to configure. In server settings under MTA you can find trusted networks option. there remove the LAN ip range and only add localhost and server IPs
cgonsalves
Posts: 8
Joined: Mon Nov 03, 2014 9:53 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby cgonsalves » Wed Nov 04, 2015 10:20 am

Did not help, the server is not on my LAN its in the data center which is a completely different subnet from my LAN.



I think its something to do here in Postfix configuration file.

/opt/zimbra/postfix/conf/main.cf

...

smtpd_relay_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

...





Clifford
eranga
Posts: 22
Joined: Sat Sep 13, 2014 3:20 am

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby eranga » Thu Nov 05, 2015 10:08 pm

post the result of the following as zimbra user. (Dont' need the IP's. But does it show your lan range?.)

postconf mynetworks
imanudin11
Outstanding Member
Outstanding Member
Posts: 297
Joined: Sat Sep 13, 2014 2:23 am
ZCS/ZD Version: Release 8.8.15.GA.3829.UBUNTU16.64
Contact:

Zimbra internal users can send mail to internal users without outgoing SMTP authentication, how do i disable this?

Postby imanudin11 » Fri Nov 06, 2015 9:52 pm

Hi,



You could configure this improvement for your problem : http://forums.zimbra.com/administrators/59106-zimbra-8-restrict-posfix-senders.html#post250465



or you can use this simple script to do that :)



wget -c http://ahmad.imanudin.com/wp-content/uploads/2014/07/automatic-sml-rus.sh



The script using Bahasa Indonesia :). However, you only need to press key Enter
**

Best Regards,
Ahmad Imanudin - Sharing is Beautiful !
Personal Blog [EN] :http://www.imanudin.net

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 14 guests