Upgrade from 8.0.4 to 8.6 Fails. Zimbra down (Urgent)

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
toger
Posts: 3
Joined: Tue Dec 15, 2015 6:04 am

Upgrade from 8.0.4 to 8.6 Fails. Zimbra down (Urgent)

Postby toger » Tue Dec 15, 2015 6:25 am

Hello,


I planned yesterday to upgrade my Zimbra 8.0.4 on ubuntu 12.04 LTS to a Ubuntu 14.04 LTS with the last ZCS 8.6


I followed the zimbra wiki upgrade procedure  here


by first upgrading my ubuntu 12.04 to 14.04. then i tried to install the ZCS 8.6 following upgrade.


As the first ./install.sh fails with the error :


can't validate LDAP


I tried ./install -s to install the software , and it succeed to perform the upgrade of the package but not sure of the zcs configuration


Now when i try to replay the upgrade, here is the result :


root@mail:~/zcs-8.6.0_GA_1153.UBUNTU14_64.20141215151116# ./install.sh

Operations logged to /tmp/install.log.20268
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
    zimbra-logger...FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU14.64
    zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU14.64
    zimbra-store...FOUND zimbra-store-8.6.0.GA.1153.UBUNTU14.64
    zimbra-apache...FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-spell...FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU14.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.6.0 will be performed.
Validating ldap configuration
Error: Unable to bind to the LDAP server as the zimbra LDAP user.
       This is required to upgrade.



I follow Jorge (update script procedure) to make sure my ldap root password is the good one but when i try to start zimbra, it fails again on the ldap start :


zimbra@mail:~$ zmcontrol start
Host mail.hopital-lamalou.fr
    Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.
567005a5 daemon: bind(7) failed errno=98 (Address already in use)
567005a5 slap_open_listener: failed on ldap://mail.hopital-lamalou.fr:389


zimbra@mail:~$ ps -aef | grep ldap
zimbra   21446     1  0 13:20 ?        00:00:00 /opt/zimbra/openldap/sbin/slapd -l LOCAL0 -u zimbra -h ldap://mail.hopital-lamalou.fr:389 ldapi:/// -F /opt/zimbra/data/ldap/config
zimbra   21475 20960  0 13:21 pts/0    00:00:00 grep ldap


The ldpa process seems to be here, but :


zimbra@mail:~$ ldap status
zimbra@mail:~$


I  have check that no one slapd.pid was there from a previous start. I kill the slapd process, removed /opt/zimbra/openldap/var/run/slapd.pid


zimbra@mail:~$ ps -aef | grep ldap
zimbra   21446     1  0 13:20 ?        00:00:00 /opt/zimbra/openldap/sbin/slapd -l LOCAL0 -u zimbra -h ldap://mail.hopital-lamalou.fr:389 ldapi:/// -F /opt/zimbra/data/ldap/config
zimbra   21758 20960  0 13:22 pts/0    00:00:00 grep ldap
zimbra@mail:~$ kill -9 21446


zimbra@mail:~$ ps -aef | grep ldap
zimbra   21762 20960  0 13:23 pts/0    00:00:00 grep ldap


zimbra@mail:~$
zimbra@mail:~$ rm -f /opt/zimbra/openldap/var/run/slapd.pid
zimbra@mail:~$ rm -f /opt/zimbra/openldap/var/run/slapd.args

zimbra@mail:~$ zmcontrol start
Host mail.hopital-lamalou.fr
    Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.
56700678 daemon: bind(7) failed errno=98 (Address already in use)
56700678 slap_open_listener: failed on ldap://mail.hopital-lamalou.fr:389


Same problem... please help me if possible, i do not know how to solve this problem.











toger
Posts: 3
Joined: Tue Dec 15, 2015 6:04 am

Upgrade from 8.0.4 to 8.6 Fails. Zimbra down (Urgent)

Postby toger » Tue Dec 15, 2015 10:35 am

Here is some new information :



./install --skip-upgrade-check



Schema upgrade required from version 92 to 103.

Running /opt/zimbra/libexec/scripts/migrate20130226_alwayson.pl

Tue Dec 15 16:51:12 2015: Verified schema version 92.

Tue Dec 15 16:51:14 2015: Verified schema version 92.

Tue Dec 15 16:51:14 2015: Updating DB schema version from 92 to 100.

Running /opt/zimbra/libexec/scripts/migrate20140319-MailItemPrevFolders.pl

Tue Dec 15 16:51:17 2015: Verified schema version 100.

Tue Dec 15 16:51:17 2015: Migrating mboxgroup1. This can take a substantial amount of time...

Tue Dec 15 16:51:25 2015: done.



Tue Dec 15 16:51:25 2015: Migrating mboxgroup10. This can take a substantial amount of time...

Tue Dec 15 16:51:32 2015: done.



....



Tue Dec 15 16:54:45 2015: Migrating mboxgroup5. This can take a substantial amount of time...

Tue Dec 15 16:54:48 2015: done.



Tue Dec 15 16:54:48 2015: Migrating mboxgroup50. This can take a substantial amount of time...

Tue Dec 15 16:54:52 2015: done.



Tue Dec 15 16:54:52 2015: Migrating mboxgroup51. This can take a substantial amount of time...

Tue Dec 15 16:54:57 2015: done.



Tue Dec 15 16:54:57 2015: Migrating mboxgroup52. This can take a substantial amount of time...

Tue Dec 15 16:55:01 2015: done.



Tue Dec 15 16:55:01 2015: Migrating mboxgroup53. This can take a substantial amount of time...

ERROR 2013 (HY000) at line 1: Lost connection to MySQL server during query

Tue Dec 15 16:55:02 2015: Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=a8IuiYs_YfxVyktEXcz3QfAp. --database=zimbra --batch --skip-column-names'.

Script failed with code 256: - exiting

UPGRADE FAILED - exiting.



---

I do not know how to complete the upgrade, because if i try to upgrade again, that time i have the error :

Upgrading from 8.0.4_GA_5737 to 8.6.0_GA_1153

Stopping zimbra services...done.

This appears to be 8.0.4_GA

Starting mysql...done.

Checking ldap status...not running.

Checking ldap status...not running.

Starting ldap...done.

Checking ldap status...already running.

Running mysql_upgrade...done.

Schema upgrade required from version 100 to 103.

Running /opt/zimbra/libexec/scripts/migrate20140319-MailItemPrevFolders.pl

Tue Dec 15 17:02:32 2015: Verified schema version 100.

Tue Dec 15 17:02:32 2015: Migrating mboxgroup1. This can take a substantial amount of time...

ERROR 1060 (42S21) at line 1: Duplicate column name 'prev_folders'

Tue Dec 15 17:02:33 2015: Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=a8IuiYs_YfxVyktEXcz3QfAp. --database=zimbra --batch --skip-column-names'.

Script failed with code 256: - exiting

UPGRADE FAILED - exiting.

---



Any help please ?
toger
Posts: 3
Joined: Tue Dec 15, 2015 6:04 am

Upgrade from 8.0.4 to 8.6 Fails. Zimbra down (Urgent)

Postby toger » Tue Dec 15, 2015 12:45 pm

Finally i succeed to continue the upgrade process...

the problem concerned a mboxgroupXX DB that was corrupted. i repair it, and then replay again manually the migrate20140319-MailItemPrevFolders.pl for the last mboxgroupXX that weren't upgraded.

Finally, i could re-start the ./install --skip-upgrade-check that ended with success.

Sorry for this alarming thread.
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Upgrade from 8.0.4 to 8.6 Fails. Zimbra down (Urgent)

Postby bhwong » Tue Dec 20, 2016 9:44 am

How do you repair it?

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 13 guests