[SOLVED] Zimbra 8.7 and letsencrypt ssl

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Posts: 41
Joined: Sat Sep 13, 2014 3:58 am

Re: [SOLVED] Zimbra 8.7 and letsencrypt ssl

Postby qadir52786 » Tue Aug 08, 2017 7:20 pm

amatu wrote:Hi jorgedlcruz and DualBoot !

Thanks guys, I will check and confirm :lol:

Please update how did you solve the problem

as cant open wiki and facing some problem while upgrading to 8.7.10

Posts: 6
Joined: Thu Sep 29, 2016 4:08 pm

Re: Zimbra 8.7 and letsencrypt ssl

Postby DennisAyala » Wed Apr 11, 2018 9:24 pm


I need to deploy Lets Encrypt Multi-SAN on a Zimpla multi-server environment. Is there any pre-requirements or additional steps I need in order to deploy them to all my servers?


Posts: 2
Joined: Mon Jun 03, 2019 9:40 pm

Re: [SOLVED] Zimbra 8.7 and letsencrypt ssl

Postby lucianoserverdo » Tue Jun 11, 2019 4:58 pm

I had the same problem, just add the Fqdn hostname in the lets encrypt list to solve

v1rtu4l wrote:Just as a little Note and warning: if you use the steps described in the Wiki and your Hostname Fqdn does not match the public domain name (which is pretty much always the case) after deployment of the lets encrypt certificates the ldap Server will fail to connect, since it somehow expects the local ldap Server to be able to be resolved on the public domain name and even after fixing this by adding an entry to the Hosts file it failed to connect to the local ldap Server, hence zimbra did not start anymore. Fortunately i had a Snapshot i could revert to.

Gesendet von meinem SM-N910F mit Tapatalk
User avatar
Advanced member
Advanced member
Posts: 53
Joined: Tue Apr 26, 2016 9:24 am
ZCS/ZD Version: Release 8.8.15.GA.3869.UBUNTU16.64

Re: [SOLVED] Zimbra 8.7 and letsencrypt ssl

Postby joho » Sun Oct 20, 2019 10:25 am

Considering how common Let's Encrypt certificates are these days (and have been, for quite some time), and what a great value they provide to system administrators and Zimbra administrators, I'm surprised there's not a function in Zimbra 8.7.x+ certificate management to simple request Let's Encrypt certificates automatically, for single domain and multii-domain (SAN) deployments, with handling of renewals, etc. Surely, it would be the best place for such things, rather than third-party scripts that may or may not work depending on which patch level of Zimbra you happen to have installed.

Posts: 1
Joined: Wed May 20, 2020 9:57 am

Re: [SOLVED] Zimbra 8.7 and letsencrypt ssl

Postby Abhishek » Wed May 20, 2020 10:03 am

amatu wrote:The case solved! Deployed and confirmed!! Thanks all!

Hi Amatu,
I am facing same issue, please give me some direction how did you fixed "zmcertmgr: ERROR: no longer runs as root!" error.


Return to “Administrators”

Who is online

Users browsing this forum: Baidu [Spider] and 13 guests