Page 1 of 1

[SOLVED] mysql.server is not running

Posted: Fri Nov 25, 2016 7:29 pm
by ElClay
I have a clean installation of Zimbra 8.7.1, Single Server, External LDAP auth, and on its third day of operation gave me this error:

zmcontrol status

Host zimbra.mydomain.com
amavis Running
antispam Running
antivirus Running
dnscache Running
ldap Running
logger Running
mailbox Stopped
mysql.server is not running.
memcached Running
mta Running
opendkim Running
proxy Running
service webapp Stopped
mysql.server is not running.
snmp Running
spell Running
stats Stopped
zimbra webapp Stopped
mysql.server is not running.
zimbraAdmin webapp Stopped
mysql.server is not running.
zimlet webapp Stopped
mysql.server is not running.
zmconfigd Running



tail -f /opt/zimbra/log/mysql_error.log

161125 14:36:01 mysqld_safe Starting mysqld daemon with databases from /opt/zimbra/db/data
2016-11-25 14:36:01 140315552028480 [Note] /opt/zimbra/common/sbin/mysqld (mysqld 10.1.14-MariaDB) starting as process 27194 ...
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: The InnoDB memory heap is disabled
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Memory barrier is not used
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Compressed tables use zlib 1.2.3
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Using Linux native AIO
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Using SSE crc32 instructions
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Initializing buffer pool, size = 8.8G
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Completed initialization of buffer pool
2016-11-25 14:36:01 140315552028480 [Note] InnoDB: Highest supported file format is Barracuda.
InnoDB: Set innodb_force_recovery to ignore this error.
2016-11-25 14:36:01 140315552028480 [ERROR] Plugin 'InnoDB' init function returned error.
2016-11-25 14:36:01 140315552028480 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2016-11-25 14:36:01 140315552028480 [Note] Plugin 'FEEDBACK' is disabled.
2016-11-25 14:36:01 140315552028480 [ERROR] Unknown/unsupported storage engine: InnoDB
2016-11-25 14:36:01 140315552028480 [ERROR] Aborting

161125 14:36:01 mysqld_safe mysqld from pid file /opt/zimbra/log/mysql.pid ended



Try to lift the service manually fails.

What could be the problem?

Re: mysql.server is not running

Posted: Fri Nov 25, 2016 7:31 pm
by DualBoot
Did you change anything into my.cnf ?
It looks like to be more related to MySQL/MariaDB than Zimbra :
https://kb.plesk.com/en/124230

Re: mysql.server is not running

Posted: Fri Nov 25, 2016 8:06 pm
by ElClay
DualBoot wrote:Did you change anything into my.cnf ?
It looks like to be more related to MySQL/MariaDB than Zimbra :
https://kb.plesk.com/en/124230


I have not made any changes in mysql (my.cnf) however with the information you provided I was able to solve the problem, although I still do not understand that I caused it.

many thanks