Page 1 of 1

Certificate on admin portal

Posted: Mon Feb 13, 2017 2:20 pm
by HansGSO
I installed a comodo certificate for my zimbra server, using this description:

https://wiki.zimbra.com/wiki/Installing ... laboration

The certificate is installed and works fine when using the standard https url to access a mailbox, but when I open the admin portal URL on port 7071 it fails.

How can I link the certificate to the admin portal?

Hans

Re: Certificate on admin portal

Posted: Tue Feb 14, 2017 2:52 pm
by arkitoure
HansGSO wrote:I installed a comodo certificate for my zimbra server, using this description:

https://wiki.zimbra.com/wiki/Installing ... laboration

The certificate is installed and works fine when using the standard https url to access a mailbox, but when I open the admin portal URL on port 7071 it fails.

How can I link the certificate to the admin portal?

Hans


Hello,

Can you explain what you mean by "it fails"? Can you not access the admin URL?
Are you running the Zimbra Proxy on the same server or have you done a multi-server setup?

Re: Certificate on admin portal

Posted: Wed Feb 15, 2017 7:58 pm
by HansGSO
I got this error in the browser:

Secure Connection Failed

see attached jpg

hans

Re: Certificate on admin portal

Posted: Wed Feb 15, 2017 11:25 pm
by vavai
Hi,
HansGSO wrote:I got this error in the browser:

Secure Connection Failed

see attached jpg

hans


AFAIK, mailbox https port 443 and Zimbra Admin https port 7071 using a same certificate, except you are using multi server install and split-dns scenario with different destination port for 443 and 7071

Re: Certificate on admin portal

Posted: Thu Feb 16, 2017 7:38 am
by HansGSO
OK,

and how does this help me?

can you explain me what I should do to fix this?

Hans

Re: Certificate on admin portal

Posted: Thu Feb 23, 2017 10:44 am
by arkitoure
HansGSO wrote:OK,

and how does this help me?

can you explain me what I should do to fix this?

Hans


There are typically 2 methods used when securing server(s) and domains.

One is a general commercial SSL for the server(s) itself, as shown in this DigiCert guide -https://www.digicert.com/csr-creation-ssl-installation-zimbra.htm
The Second is through SNI, for individual domains within the entire mail service - https://wiki.zimbra.com/wiki/Multiple_S ... ation_(SNI)_for_HTTPS

If you have a multi-server install you would need to install an SSL Cert for each server (ie; proxy, mta, ldap...etc). Typically this can be done by using a wildcard certificate if operating within the same domain. The server level SSL's should secure your admin login without any extra configuration. Make sure you are going to https://yourdomain.com:7071

Can you explain your current setup more so we can help better? Is it a single server install or multi-server install? If it is multi-server install how many separate servers have you set up?

Re: Certificate on admin portal

Posted: Fri Feb 24, 2017 9:34 am
by HansGSO
Hi

You are right, there are 2 servers.

I never realized this, because I did an automatic (default) installation.

I found a second certificate installation option in the admin portal, this fixed the issue.

Thank you!

Hans