ActiveSync Autodiscover using wrong port

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
nticompass
Posts: 5
Joined: Tue Feb 07, 2017 6:12 am

ActiveSync Autodiscover using wrong port

Postby nticompass » Wed Oct 18, 2017 3:03 pm

I recently migrated our zimbra accounts to a new, clean server with a fresh install and I've had a few issues with it.

A client, who is using Outlook 2013 is having issues. I do not have Outlook, so I am testing with https://testconnectivity.microsoft.com

I ran a test and see the following from autodiscover:

Code: Select all

<?xml version="1.0"?>
<Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
<User>
<DisplayName>EmailTest</DisplayName>
<DeploymentId>8eb380b1-cbf6-4a46-8e39-db8ddada9633</DeploymentId>
</User>
<Account>
<AccountType>email</AccountType>
<Action>settings</Action>
<Protocol>
<Type>EXCH</Type>
<ASUrl>https://zimbra.example.com:8443/ews/Exchange.asmx</ASUrl>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<EwsUrl>https://zimbra.example.com:8443/ews/Exchange.asmx</EwsUrl>
</Protocol>
</Account>
</Response>
</Autodiscover>


Why is is showing port 8443? That is not open in our firewall, and shouldn't be since it's zimbra's internal port. This should be port 443 (or just https://zimbra.example.com) since that will use the nginx proxy to get it to 8443 internally.

How do I make zimbra use the correct port in activesync autodiscover?

Related to this, is when I use the "view mail" feature in the admin console, it ALSO tries to use port 8443, why? Why doesn't zimbra realize that port 8443 cannot be accessed from the outside?

To fix this, I tried running the following:

Code: Select all

zmprov mcf zimbraPublicServicePort 443
/opt/zimbra/libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x https -H `zmhostname`


Neither of those fixed the issue. Is this a bug; should I file a bug report?


Return to “Administrators”

Who is online

Users browsing this forum: jorgedlcruz and 18 guests