Page 2 of 3

Re: Insane cpu usage by zmmailboxd

Posted: Thu Feb 15, 2018 9:07 am
by comradeTJH
I encountered a similar problem after upgrading from 8.7.11 to 8.8.6. Upgrade-process was seamless and without any problems. Everything runs very smoothly and snappy for some hours and then suddenly, the java-processes start using all the CPU and all services gradually degrades until they become completely unresponsive. (IMAP, webinterface, admin-interface, everything)

zmmailboxdctl restart fixes the problem temporarly.

Any ideas how to troubleshoot?

Re: Insane cpu usage by zmmailboxd

Posted: Fri Feb 16, 2018 4:17 pm
by comradeTJH
Hey guys, heads up - installing the last patch fixed it for me :-) : https://wiki.zimbra.com/wiki/Zimbra_Rel ... 8.6_HotFix

Re: Insane cpu usage by zmmailboxd

Posted: Mon Feb 19, 2018 9:18 am
by matteo.fracassetti
I'll try as soon as possible.
Thank you.

Re: Insane cpu usage by zmmailboxd

Posted: Mon Feb 19, 2018 10:52 am
by matteo.fracassetti
...
Just some minutes after reply to comradeTJH suggestion, I checked our servers monitor.... And the issue seems has been solved itself! I done last "zmmailboxdctl restart" on 15 Feb at 16:29:50 and, after that, CPU Load Average hasn't grow anymore, it keeps under 2.

Nothing else was done by me or by my collegues... Many thanks to Harry Potter but is very frustrating when those magic events happen.

Re: Insane cpu usage by zmmailboxd

Posted: Mon Feb 26, 2018 1:55 pm
by lfasci
I have the same problem on ubuntu 14.04.5 and zimbra 8.8.6 with patch applied, IMAP kills the server.
It was a n opensource edition upgraded to Network

Re: Insane cpu usage by zmmailboxd

Posted: Mon Feb 26, 2018 2:03 pm
by L. Mark Stone
lfasci wrote:I have the same problem on ubuntu 14.04.5 and zimbra 8.8.6 with patch applied, IMAP kills the server.
It was a n opensource edition upgraded to Network


The patch does not upgrade your OSE Zimbra to Network Edition, but the patch is a replacement jar file for mailboxd and Zimbra wanted to get it out quickly, so there is just one identical patch for both NE and OSE at the moment. As a result, it reports itself as NE, but as you probably know there is a lot more to NE than just this one jar file.

To my understanding, the next point release will address this.

Hope that helps,
Mark

Re: Insane cpu usage by zmmailboxd

Posted: Mon Mar 19, 2018 10:03 am
by matteo.fracassetti
Last weekend the issue appears again...

I'll try to update our server to the latest release, hoping it helps.

Re: Insane cpu usage by zmmailboxd

Posted: Wed Mar 21, 2018 10:18 am
by unaiSolaguren
I have updated from 8.7.1 to 8.8.6 on Ubuntu 14.04, the issue persists. This weekend I will try to update to Ubuntu 16.04

Anyway, the process that most CPU consumes is...

Code: Select all

# cat /proc/13270/cmdline
/opt/zimbra/common/bin/java-Dfile.encoding=UTF-8-server-Djava.awt.headless=true-XX:+UseConcMarkSweepGC-XX:+UseParNewGC-XX:NewRatio=2-XX:PermSize=196m-XX:MaxPermSize=350m-XX:SoftRefLRUPolicyMSPerMB=1-verbose:gc-XX:+PrintGCDetails-XX:+PrintGCTimeStamps-XX:+PrintGCApplicationStoppedTime-XX:+HeapDumpOnOutOfMemoryError-XX:HeapDumpPath=/opt/zimbra/log-XX:ErrorFile=/opt/zimbra/log/hs_err_pid%p.log-Xss256k-Dsun.net.inetaddr.ttl=60-Xms2048m-Xmx2048m-Xmn614m-Djava.io.tmpdir=/opt/zimbra/mailboxd/work-Djava.library.path=/opt/zimbra/lib-Djava.endorsed.dirs=/opt/zimbra/mailboxd/common/endorsed-Dzimbra.config=/opt/zimbra/conf/localconfig.xml-Djetty.base=/opt/zimbra/mailboxd-Djetty.home=/opt/zimbra/common/jetty_home-DSTART=/opt/zimbra/mailboxd/etc/start.config-jar/opt/zimbra/common/jetty_home/start.jar--module=zimbra,server,servlet,servlets,jsp,jstl,jmx,resources,websocket,ext,plus,rewrite,monitor,continuation,webapp,setuidjetty.home=/opt/zimbra/common/jetty_homejetty.base=/opt/zimbra/mailboxd/opt/zimbra/mailboxd/etc/jetty.xml

Re: Insane cpu usage by zmmailboxd

Posted: Wed Mar 21, 2018 12:30 pm
by msquadrat
You should try 8.8.7 first.

Re: Insane cpu usage by zmmailboxd

Posted: Mon Mar 26, 2018 10:58 am
by unaiSolaguren
The last week I' tried the 8.8.7 on ubuntu 14.04, but the processor performance was bad, after that I installed the patch for the bugs Bug 108839 and Bug 108414 with no results. With all these changes the java processors consumes all the CPU.

The last friday I've updated the ubuntu from 14.04 to 16.04 and today it's the first working day. It's running correctly, the cpu and memory consume are ok.

Thanks for the support.