32 to 64 bit Upgrade issue - BES Searcher password

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Cryophallion
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 10:28 pm

32 to 64 bit Upgrade issue - BES Searcher password

Postby Cryophallion » Mon Feb 06, 2012 8:43 am

I am trying to test out a move from Ubuntu 8.04 32 bit to 10.04 64 bit. Due to a hard drive failure, I am running the old version off a virtual machine while I do the tests, but I'd like to get up and running on the server ASAP.
Version of zimbra is current version (7.1.4) on all versions.
I followed the instructions on the wiki, but only afterwards realized that the mail port had been 81 on the old version, but set to 80 in the new version, which is why I assumed I got a zmmailboxdctl is not running error when I started up the new instance.
I tried to us zmprov to fix this, but I got the following error:

[] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused

[] INFO: Retrying request

ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)


I decided to do an "upgrade" to redo the settings, but now when it gets to that part, it gives me the asterisks next to the ldap bes searcher password saying it is unverified, and nothing I try works.
Can anyone help get me over this hurdle to get back up and running?


User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

32 to 64 bit Upgrade issue - BES Searcher password

Postby quanah » Mon Feb 06, 2012 6:25 pm

Did you use the menu to set a password for it?
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
Cryophallion
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 10:28 pm

32 to 64 bit Upgrade issue - BES Searcher password

Postby Cryophallion » Mon Feb 06, 2012 6:45 pm

I tried, but it kept labeling it "unverified" I believe. I'm trying for a third time tomorrow. I think that that may be the only password that is not in my old xml settings, but it is still extremely frustrating.
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

32 to 64 bit Upgrade issue - BES Searcher password

Postby quanah » Mon Feb 06, 2012 6:48 pm

Ok, interesting. :/ Do you know what it is logging in the setup log in /tmp when you set a value for it? I thought this was fixed in 7.1.3 (bug#64401)
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
Cryophallion
Advanced member
Advanced member
Posts: 56
Joined: Fri Sep 12, 2014 10:28 pm

32 to 64 bit Upgrade issue - BES Searcher password

Postby Cryophallion » Tue Feb 07, 2012 8:47 am

Below is the output. I DID fix the main issue mentioned above (certs issues), but I decided to test if this bug still exists.
Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.

Tue Feb 7 09:45:04 2012 Verified uid=zmamavis,cn=appaccts,cn=zimbra on mail.example.com.

Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389

Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.

Tue Feb 7 09:45:04 2012 Verified uid=zimbra,cn=admins,cn=zimbra on mail.example.com.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_ldap_password=maxum1.

Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389

Tue Feb 7 09:45:04 2012 Unable to bind to ldap://mail.example.com:389 with user uid=zmbes-searcher,cn=appaccts,cn=zimbra:

Tue Feb 7 09:45:04 2012 Couldn't bind to mail.example.com as uid=zmbes-searcher,cn=appaccts,cn=zimbra

Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389

Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.

Tue Feb 7 09:45:04 2012 Verified uid=zmpostfix,cn=appaccts,cn=zimbra on mail.example.com.

Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389

Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.

Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.

Tue Feb 7 09:45:04 2012 Verified uid=zmamavis,cn=appaccts,cn=zimbra on mail.example.com.

Tue Feb 7 09:45:05 2012 checking isEnabled zimbra-ldap

Tue Feb 7 09:45:05 2012 zimbra-ldap is enabled
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

32 to 64 bit Upgrade issue - BES Searcher password

Postby quanah » Tue Feb 07, 2012 5:52 pm

You can get around this for now by finding the following code block in zmsetup.pl:


# check zmbes searcher binding to the master

if ($config{LDAPHOST} eq $config{HOSTNAME}) {

if ($config{ldap_bes_searcher_password} eq "") {

detail ("BES searcher configuration not complete
");

$failedcheck++;

}

my $binduser = "uid=zmbes-searcher,cn=appaccts,$config{ldap_dit_base_dn_config}";

if (checkLdapBind($binduser,$config{ldap_bes_searcher_password})) {

detail ("Couldn't bind to $config{LDAPHOST} as $binduser
");

$config{LDAPBESSEARCHSET} = "Not Verified";

$failedcheck++;

} else {

detail ("Verified $binduser on $config{LDAPHOST}.
");

$config{LDAPBESSEARCHSET} = "set";

}

}


Remove the if... through else ... lines, and the first } after the else line, that'll skip checking that it is valid, and let you proceed with the install.
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
ekkas
Advanced member
Advanced member
Posts: 112
Joined: Sat Sep 13, 2014 1:03 am

32 to 64 bit Upgrade issue - BES Searcher password

Postby ekkas » Mon Jul 23, 2012 12:55 am

[quote user="quanah"]You can get around this for now by finding the following code block in zmsetup.pl:
[/QUOTE]
I had same issue upgrading from 7.1.3 to 7.2.0

Stopping installation when I got stuck, edited file mentioned above, then ran it seemed to complete install.


Ekkas
batfastad
Outstanding Member
Outstanding Member
Posts: 281
Joined: Fri Sep 12, 2014 10:43 pm

32 to 64 bit Upgrade issue - BES Searcher password

Postby batfastad » Sun Mar 24, 2013 6:49 pm

Just tried to upgrade from 7.2.0 to 7.2.3 and this problem nailed me for some reason.

Hacking /opt/zimbra/libexec/zmsetup.pl as above has not worked!!! :(
ae-dlund
Posts: 1
Joined: Sat Sep 13, 2014 1:56 am

32 to 64 bit Upgrade issue - BES Searcher password

Postby ae-dlund » Wed Apr 17, 2013 11:45 am

After coming upon this issue myself I worked with Zimbra support to resolve this.
I noticed that this is the first thread that comes up in a google search regarding this issue so I'm putting the fix here for anyone that comes upon it.
When you get to the point in the install where it says the BES Searcher is "Not Verified", open another terminal window and run this command as the zimbra user: zmldappasswd -b password
Then go back to your install terminal screen and address the unconfigured BES searcher password (press enter to confirm the password it shows for BES Searcher).
Press 'r' to return to the previous menu and configuration should be complete.
MACscr
Advanced member
Advanced member
Posts: 127
Joined: Sat Sep 13, 2014 1:19 am

32 to 64 bit Upgrade issue - BES Searcher password

Postby MACscr » Fri Nov 08, 2013 4:47 am

[quote user="ae-dlund"]After coming upon this issue myself I worked with Zimbra support to resolve this.
I noticed that this is the first thread that comes up in a google search regarding this issue so I'm putting the fix here for anyone that comes upon it.
When you get to the point in the install where it says the BES Searcher is "Not Verified", open another terminal window and run this command as the zimbra user: zmldappasswd -b password
Then go back to your install terminal screen and address the unconfigured BES searcher password (press enter to confirm the password it shows for BES Searcher).
Press 'r' to return to the previous menu and configuration should be complete.[/QUOTE]
why after all this time, does this bug still exist? Its extremely frustrating having to deal with it after each upgrade. Especially since i do not even use BES!

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 13 guests