LMTP Delivery - mailop Adding - Logging per account

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
stasouv
Posts: 45
Joined: Sat Sep 13, 2014 2:25 am
ZCS/ZD Version: Release 8.8.8_GA_2009.RHEL7_64_2018

LMTP Delivery - mailop Adding - Logging per account

Postby stasouv » Tue Apr 24, 2018 7:47 am

Greetings,

Zimbra edition: Release 8.8.8_GA_2009.RHEL7_64_20180322150747 RHEL7_64 FOSS edition.

In one of our previous installation, whenever a message arrived to multiple internal recipients, there would exist one line per recipient in /opt/zimbra/mailbox.log.
This line would print "Adding message...."
This line would connect the messageId, the mailbox id and the received-message-id.

Now, in 8.8.8, we are still getting the Delivering line, but it does not split to Adding lines for relative accounts. So, we are getting something like:

Code: Select all

2018-04-24 10:01:29,674 INFO  [LmtpServer-18] [ip=XXXXXXX;] lmtp - Delivering message: size=9734 bytes, [b][u]nrcpts=15[/u][/b], sender=someone@there.com, msgid=<20180424070059.64CAB282900@mail.there.com>


I would like to have logged one line for each recipient, as it was in previous version, something like (copied from a post in this forum):

Code: Select all

2011-11-18 12:37:46,052 INFO  [LmtpServer-1] [name=internal_user@example.com;mid=X;ip=XXXXXXX;] mailop - Adding Message: id=264, Message-ID=, parentId=-1, folderId=2, folderName=Inbox.



Is there a configuration option to fix this, so it behaves as it used to in previous versions?


stasouv
Posts: 45
Joined: Sat Sep 13, 2014 2:25 am
ZCS/ZD Version: Release 8.8.8_GA_2009.RHEL7_64_2018

Re: LMTP Delivery - mailop Adding - Logging per account

Postby stasouv » Tue Apr 24, 2018 8:21 am

I realized by examining that all mailop lines in log, are "INFO" lines. So, apparently, I have to change to "DEBUG".

After reading a bit further and, mostly, trying to understand between the lines, I ended up doing the following:

- I appended this line to conf/log4j.properties

Code: Select all

log4j.logger.zimbra.mailop=DEBUG


- Tested that it was correct (hot reload)

Code: Select all

zmprov rlog


This helped me see that, indeed, DEBUG was my friend. So, I added the above line again to conf/log4j.properties.in to make changes permanent.

Problem solved!

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 40 guests