Page 1 of 1

zimbraMailTrustedIP not working

Posted: Fri May 31, 2019 12:19 pm
by bqeg
Hello. I've searched a lot to find a solution to the problem I'm facing, with no luck.

I have an application that connects to my zimbra server by iMap. Recently the emails are not being sent with the status:

Timeout or connection closed SMTP communication log: 2019-05-31-04-25-36-5116 Sent: QUIT 2019-05-31-04-25-42-0533 Recv: 220 myhost ESMTP Postfix

I've followed the instructions on https://wiki.zimbra.com/wiki/DoSFilter and tried everything, like increasing the number of requests per second, reducing the delay, etc with no luck. One thing I've noticed is that the whitelist is not working despite I'm adding the ips I want to whitelist.

When I run zmprov gcf zimbraHttpThrottleSafeIPs the IP of my application is there. But when I run zmmailboxdctl restart the IP is not being show as whitelisted in /opt/zimbra/log/mailbox.log.

So I assume that the whitelist is not working for some reason.

My version is: Release 8.8.9_GA_3019.RHEL7_64_20180809160254 RHEL7_64 FOSS edition, Patch 8.8.9_P4.
I'm using CENTOS7.

Any help would be much appreciated.

Regards,

Re: zimbraMailTrustedIP not working

Posted: Sun Jun 02, 2019 9:29 pm
by fs.schmidt
Hi,

The DosFilter is applied for the mailbox services indeed, but if your application is trying to send emails it isn't using IMAP, it's using SMTP.

Have you analysed your /var/log/zimbra.log to check what happened to those sent messages?

Best regards.
Fabio S. Schmidt