Page 2 of 4

Re: SpamAssassin not learning

Posted: Mon Aug 19, 2019 12:02 pm
by guilhermehnog
andrey.ivanov wrote:The exception is in the com.zimbra.common.httpclient.HttpClientUtil class. It could be a new Zimbra bug related to the major change of version of HttpCLient ("Upgraded 3rd Party HttpClient to version 4.5.5." from https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15).

There is already a known issue with the same reason, with a workaround "WebMail Login Failure - when zimbraCsrfTokenCheckEnabled is set to FALSE Apache HttpClient Connection pool shuts down and login to webmail fails.". So maybe it's a second side effect of HttpClient upgrade in 8.8.15...


Interesting ...
zimbraCsrfTokenCheckEnabled is set to TRUE though

Code: Select all

[zimbra@mail ~]$ zmprov gacf | grep zimbraCsrfTokenCheckEnabled
zimbraCsrfTokenCheckEnabled: TRUE


How can we send that to developers to analyze. do i need zimbra network edition for that?

Re: SpamAssassin not learning

Posted: Mon Aug 19, 2019 11:12 pm
by L. Mark Stone
8.8.15 Patch 1 is due out this week. Will be interesting to see if the Release Notes cover this.

All the best,
Mark

Re: SpamAssassin not learning

Posted: Tue Aug 20, 2019 9:10 am
by andrey.ivanov
guilhermehnog wrote:
andrey.ivanov wrote:The exception is in the com.zimbra.common.httpclient.HttpClientUtil class. It could be a new Zimbra bug related to the major change of version of HttpCLient ("Upgraded 3rd Party HttpClient to version 4.5.5." from https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15).

There is already a known issue with the same reason, with a workaround "WebMail Login Failure - when zimbraCsrfTokenCheckEnabled is set to FALSE Apache HttpClient Connection pool shuts down and login to webmail fails.". So maybe it's a second side effect of HttpClient upgrade in 8.8.15...


Interesting ...
zimbraCsrfTokenCheckEnabled is set to TRUE though

Code: Select all

[zimbra@mail ~]$ zmprov gacf | grep zimbraCsrfTokenCheckEnabled
zimbraCsrfTokenCheckEnabled: TRUE


How can we send that to developers to analyze. do i need zimbra network edition for that?


Yes, you need a supported Network Edition. I do have support but unfortunately i still have not tested 8.8.15 to reproduce your problem and make a ticket. As Mark says, maybe the 8.8.15_P1 will fix this problem.

Re: SpamAssassin not learning

Posted: Fri Aug 30, 2019 8:11 am
by pup_seba
Hi,

On CentOS 7.6, 8.8.15p1 is not solving the problem with either FOSS or NE editions. I could not see either this problem described in the "known issues".

Regards,

Re: SpamAssassin not learning

Posted: Fri Aug 30, 2019 9:19 am
by slacker1337
Hello guys,

same issue here - Zimbra 8.8.15 NE and FOSS too. I opened a support ticket on 23. august. Zimbra support was able to reproduce it on their test servers and allegedly the update to 8.8.15_P1 solved the problem on their side. But not in my case. Tried updating both the NE and FOSS and I'm still experiencing the issue.

Maybe the next patch will cover this, but it would be nice to see some workaround before.. :(

Re: SpamAssassin not learning

Posted: Sat Aug 31, 2019 10:14 am
by bb101
We are experiencing the same problem too. Our mailboxes' spam false negatives have rocketed over the past couple of weeks.

I was hoping Zimbra/Synacor would be on the case and have fixed it in 8.8.15_patch1 but they haven't. Not sure why.

Code: Select all

Exception in thread "main" java.lang.NullPointerException
   at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:53)
   at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:49)
   at com.zimbra.cs.util.SpamExtract.extractMessages(SpamExtract.java:367)
   at com.zimbra.cs.util.SpamExtract.extract(SpamExtract.java:291)
   at com.zimbra.cs.util.SpamExtract.main(SpamExtract.java:220)

Re: SpamAssassin not learning

Posted: Sat Aug 31, 2019 10:54 am
by phoenix
A better solution, IMO, would be to replace SpamAssassin with Rspamd. :)

Re: SpamAssassin not learning

Posted: Sat Aug 31, 2019 8:36 pm
by thefantas
bb101 wrote:We are experiencing the same problem too. Our mailboxes' spam false negatives have rocketed over the past couple of weeks.

I was hoping Zimbra/Synacor would be on the case and have fixed it in 8.8.15_patch1 but they haven't. Not sure why.

Code: Select all

Exception in thread "main" java.lang.NullPointerException
   at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:53)
   at com.zimbra.common.httpclient.HttpClientUtil.executeMethod(HttpClientUtil.java:49)
   at com.zimbra.cs.util.SpamExtract.extractMessages(SpamExtract.java:367)
   at com.zimbra.cs.util.SpamExtract.extract(SpamExtract.java:291)
   at com.zimbra.cs.util.SpamExtract.main(SpamExtract.java:220)

I just updated Zimbra to the latest version 8.8.15 P1 and I have the same error, they haven't updated it.

Re: SpamAssassin not learning

Posted: Sun Sep 01, 2019 10:32 pm
by guilhermehnog
Patch 1 did not solve our problem either.

Doing some tests to see if something else changed.

Re: SpamAssassin not learning

Posted: Wed Sep 11, 2019 8:09 pm
by stolen time
Same here too. I just decided to re-install rather than upgrade so it's a clean install - ZCS 8.8.15 open source (patch 1, provided that "apt upgrade" is all you have to do nowadays to patch) on Ubuntu 18.04.3 server.

It looks as if "spamtrain.log" contains nothing but these errors, and the Bayes filter has not started, so I suspect no training at all is happening.