Page 1 of 1

Having an issue with CLAMD

Posted: Wed Oct 23, 2019 1:39 pm
by FredKarno
I've got a support case open with Zimbra but it seems to be handled in western US time, which isn't ideal when you're GMT...


Recently I b0rked the server a bit by letting it run out of disk space. Eventually I deleted enough logs to run zmbackup query and remove the large number of backups that were clogging the system.OK mea culpa, time for hierarchical storage etc.

When I restarted the services they all came up except antivirus. So all our emails were coming up ***Unchecked*** in the title which is annoying my users (we've got other AV scans in place so the lack of clamd isn't crucial atm)

I also had some firewall config issues which were preventing the server from reaching anything via http/s so although email was flowing, I couldn't use yum update or run a clam update.

On the advice of Zimbra support I did the following:

zmprov ms `zmhostname` -zimbraServiceEnabled antivirus

zmconfigdctl restart

zmantivirusctl stop

zmcontrol status <<== antivirus should not be displayed

However, despite the antivirus service not being displayed, I was still getting the ***Unchecked*** message in all email titles.

I have now resolved the network issues and would like to re-enable and restart clam.d
So, I tried something I thought was logical: ]zmprov ms `zmhostname` zimbraServiceEnabled antivirus
and hit an error which I failed to save but said something like "Can't do that on multiple items unless you use -r"
So I tried that with
]zmprov ms -r `zmhostname` -zimbraServiceEnabled antivirus

and broke all the services on the server. Luckily I had a snapshot and reverted. This was naughty but my only option :(

Does anyone have any ideas on how I can get clamd sorted again please?

edit: Version 8.8.11 P4

Re: Having an issue with CLAMD

Posted: Wed Oct 23, 2019 1:58 pm
by FredKarno
Sometimes it's the simple act of sharing that helps you progress :)

I realised my error. + was required.
From there, I was able to reverse the instructions from Zimbra support and it's now working.

Thanks for being there!!