Page 1 of 2

Unknown command sent to server. ZxChatRequest

Posted: Mon Jan 06, 2020 9:19 pm
by ale.adco94
I have updated to version 8.8.12 >> 8.8.15. The process apparently was successful, however when I log in to the web client I get the following error.

Code: Select all

Comando desconocido enviado al servidor. ZxChatRequest
method:   [unknown]
msg:   unknown document: ZxChatRequest
code:   service.UNKNOWN_DOCUMENT
detail:   soap:Sender
trace:   qtp366590980-81:1578342519951:6b913a7a36d1942d
request:   
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Header><context xmlns="urn:zimbra"><userAgent name="ZimbraWebClient - GC79 (Win)" version="8.8.15_GA_3890"/><session id="15"/><account by="name">user@midominio.com</account><format type="js"/><csrfToken>0_9b547fb6529d130720d8f70dcb8067bd8ac4e784</csrfToken></context></soap:Header><soap:Body><ZxChatRequest xmlns="urn:zimbraAccount"><type>16</type><clientVersion>13</clientVersion><action>register_session</action></ZxChatRequest></soap:Body></soap:Envelope>

I already made apt remove and apt install of zimbra-chat according to some suggestions I saw in forums from years ago and still the error follows.

Re: Unknown command sent to server. ZxChatRequest

Posted: Tue Jan 07, 2020 11:13 am
by fayaz
hi

its a jdk problem . you have to disale chat from COS then it will work fine. but your chat will be disabled. let wait for zimbra update for this .

Re: Unknown command sent to server. ZxChatRequest

Posted: Tue Jan 07, 2020 8:50 pm
by ale.adco94
Thank you for your response fayaz, happy and successful 2020

Re: Unknown command sent to server. ZxChatRequest

Posted: Thu Jan 09, 2020 3:05 pm
by rport
Just posted this in another thread about zimbra chat. Perhaps this will help too:

mv /opt/zimbra/lib/ext/openchat/zal.jar /tmp
cp -rp /opt/zimbra/lib/ext/zimbradrive/zal.jar /opt/zimbra/lib/ext/openchat/zal.jar
su - zimbra
zmmailboxdctl restart


rp0rt

Re: Unknown command sent to server. ZxChatRequest

Posted: Tue Jan 14, 2020 4:46 pm
by tonyawbrey
rport wrote:Just posted this in another thread about zimbra chat. Perhaps this will help too:

mv /opt/zimbra/lib/ext/openchat/zal.jar /tmp
cp -rp /opt/zimbra/lib/ext/zimbradrive/zal.jar /opt/zimbra/lib/ext/openchat/zal.jar
su - zimbra
zmmailboxdctl restart


rp0rt



Thanks for posting this I followed these instructions and it resolved my issue.

Tony

Re: Unknown command sent to server. ZxChatRequest

Posted: Fri Jan 17, 2020 8:38 am
by PavanLinux
Confirmed that 8.8.15 chat issue resolved with below step which is provided by above thread. Thank you

# mv /opt/zimbra/lib/ext/openchat/zal.jar /tmp
# cp -rp /opt/zimbra/lib/ext/zimbradrive/zal.jar /opt/zimbra/lib/ext/openchat/zal.jar
# su - zimbra
$ zmmailboxdctl restart

If chat zimlet is disabled then enable Chat Zimlet from Admin Console > Configure > Zimlets > com_zimbra_open_chat <toggle>
Login to user mailbox using Zimbra web client and you will see chat window on right hand side.

Thank you!

Re: Unknown command sent to server. ZxChatRequest

Posted: Mon Jan 20, 2020 2:37 pm
by fayaz
hi

Perfectly work for me !!!

Thanks to all

Re: Unknown command sent to server. ZxChatRequest

Posted: Tue Jan 21, 2020 9:59 am
by plagoutte
Hello,

It worked for me too, thanks !

PL

Re: Unknown command sent to server. ZxChatRequest

Posted: Sat Feb 01, 2020 8:13 pm
by allende8807
rport wrote:Just posted this in another thread about zimbra chat. Perhaps this will help too:

mv /opt/zimbra/lib/ext/openchat/zal.jar /tmp
cp -rp /opt/zimbra/lib/ext/zimbradrive/zal.jar /opt/zimbra/lib/ext/openchat/zal.jar
su - zimbra
zmmailboxdctl restart


rp0rt


Just upgrading from 8.8.15_P4 to Patch 8.8.15_P6 and facing this error. Thanks for helping. Work perfect!!!

Re: Unknown command sent to server. ZxChatRequest

Posted: Wed Feb 19, 2020 12:52 pm
by Sub-Zero
rport wrote:Just posted this in another thread about zimbra chat. Perhaps this will help too:
mv /opt/zimbra/lib/ext/openchat/zal.jar /tmp
cp -rp /opt/zimbra/lib/ext/zimbradrive/zal.jar /opt/zimbra/lib/ext/openchat/zal.jar
su - zimbra
zmmailboxdctl restart
rp0rt

It doesn't work. I don't have an "openchat" folder in /opt/zimbra/lib/ext at all and all these commands give an error. I have 8.8.15_GA_3869 NETWORK installed on CentOS 7. When I try to install zimbra-chat, I get an error - that zimbra-talk is already installed and conflicts with zimbra-chat. For reference I have this modules:
zimbra-drive...FOUND zimbra-drive-1.0.13.1576152256-1
zimbra-chat...NOT FOUND
zimbra-talk...FOUND zimbra-talk-4.0.2.1554992028-1