String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
jnoel
Posts: 3
Joined: Sun Nov 19, 2017 1:54 am

String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby jnoel » Thu Feb 13, 2020 11:58 am

Since patch 6 or 7 of zimbra 8.8.15, in an html mail the string "&num" is converted to "#" by the zimbra webmail.

It's very annoying when you receive a url containing these characters: the link becomes invalid.

By example if someone send me :
<a href="http://example.com/&num=1">http://example.com/&num=1</a>

I receive :
<a href="http://example.com/#=1">http://example.com/#=1</a>

I filed a bug report here : https://bugzilla.zimbra.com/show_bug.cgi?id=109290


Inglebard
Posts: 21
Joined: Fri Jul 20, 2018 9:18 am

Re: String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby Inglebard » Fri Feb 14, 2020 2:28 pm

Hi,

I encoutered the same issue today.

Do you find a solution or a woraround ?
jnoel
Posts: 3
Joined: Sun Nov 19, 2017 1:54 am

Re: String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby jnoel » Sat Feb 15, 2020 3:54 am

not yet
I'm still looking.
Inglebard
Posts: 21
Joined: Fri Jul 20, 2018 9:18 am

Re: String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby Inglebard » Mon Feb 17, 2020 8:52 am

Do you have notice something special about the mail which has the issue ?

Because when i send a link with &num, it is not always converted.
zimbraLuis
Posts: 10
Joined: Tue May 28, 2019 9:55 am

Re: String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby zimbraLuis » Tue Feb 18, 2020 10:22 am

Hello,

Put the parameter :

zmlocalconfig -e zimbra_use_owasp_html_sanitizer=true
zmmailboxdctl restart

It's resolve issue for me.

Regards,
Luis
jnoel
Posts: 3
Joined: Sun Nov 19, 2017 1:54 am

Re: String "&num" is converted by the webmail after upgrade in 8.8.15 P6

Postby jnoel » Sun Mar 29, 2020 8:00 pm

zimbraLuis wrote:zmlocalconfig -e zimbra_use_owasp_html_sanitizer=true
zmmailboxdctl restart


Thanks Luis, it's works for me.

Return to “Administrators”

Who is online

Users browsing this forum: fnortech and 16 guests