Page 1 of 1

I changed the hostname, now I can't start LDAP.

Posted: Tue Mar 03, 2020 7:16 am
by yohoho
Hello, my name is Jason.

This is what I've done

1. The domain is expired [I don't know that it's going to expire this year]
2. I follow this article https://wiki.zimbra.com/wiki/ZmSetServerName

Code: Select all

/opt/zimbra/bin/zmcertmgr createca -new
/opt/zimbra/bin/zmcertmgr createcrt -new -subjectAltNames mail -days 365
/opt/zimbra/bin/zmcertmgr deploycrt self
/opt/zimbra/bin/zmcertmgr deployca
/opt/zimbra/bin/zmcertmgr viewdeployedcrt
zmcontrol restart


3. I change the hostname to new domain.

This is the error I receive when "zmcontrol restart"

Code: Select all

Host mysarana.com
        Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.
5e5e02a3 daemon: bind(7) failed errno=99 (Cannot assign requested address)
5e5e02a3 slap_open_listener: failed on ldap://mysarana.com:389


If you know how to fix this, please help.

Sincerely,
Jason

Re: I changed the hostname, now I can't start LDAP.

Posted: Tue Mar 03, 2020 8:02 am
by yohoho
I tried to tweak around.

zmcontrol restart

This is what I got.

Code: Select all

Host mysarana.com
        Stopping zmconfigd...Done.
        Stopping zimlet webapp...Done.
        Stopping zimbraAdmin webapp...Done.
        Stopping zimbra webapp...Done.
        Stopping service webapp...Done.
        Stopping stats...Done.
        Stopping mta...Done.
        Stopping spell...Done.
        Stopping snmp...Done.
        Stopping cbpolicyd...Done.
        Stopping archiving...Done.
        Stopping opendkim...Done.
        Stopping amavis...Done.
        Stopping antivirus...Done.
        Stopping antispam...Done.
        Stopping proxy...Done.
        Stopping memcached...Done.
        Stopping mailbox...Done.
        Stopping logger...Done.
        Stopping dnscache...Done.
        Stopping ldap...Done.
Host mysarana.com
        Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.



zimbra@mail:/home/mysarana$


ldap start

Code: Select all

zimbra@mail:/home/mysarana$ ldap start
Failed to start slapd.  Attempting debug start to determine error.
5e5e1239 daemon: bind(7) failed errno=99 (Cannot assign requested address)
5e5e1239 slap_open_listener: failed on ldap://mysarana.com:389

Re: I changed the hostname, now I can't start LDAP.

Posted: Tue Mar 03, 2020 8:07 am
by fferraro87
yohoho wrote:I tried to tweak around.

zmcontrol restart

This is what I got.

Code: Select all

Host mysarana.com
        Stopping zmconfigd...Done.
        Stopping zimlet webapp...Done.
        Stopping zimbraAdmin webapp...Done.
        Stopping zimbra webapp...Done.
        Stopping service webapp...Done.
        Stopping stats...Done.
        Stopping mta...Done.
        Stopping spell...Done.
        Stopping snmp...Done.
        Stopping cbpolicyd...Done.
        Stopping archiving...Done.
        Stopping opendkim...Done.
        Stopping amavis...Done.
        Stopping antivirus...Done.
        Stopping antispam...Done.
        Stopping proxy...Done.
        Stopping memcached...Done.
        Stopping mailbox...Done.
        Stopping logger...Done.
        Stopping dnscache...Done.
        Stopping ldap...Done.
Host mysarana.com
        Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.



zimbra@mail:/home/mysarana$

do you've check also file /etc/hosts ?

Re: I changed the hostname, now I can't start LDAP.

Posted: Tue Mar 03, 2020 8:19 am
by yohoho
fferraro87 wrote:
yohoho wrote:I tried to tweak around.

zmcontrol restart

This is what I got.

Code: Select all

Host mysarana.com
        Stopping zmconfigd...Done.
        Stopping zimlet webapp...Done.
        Stopping zimbraAdmin webapp...Done.
        Stopping zimbra webapp...Done.
        Stopping service webapp...Done.
        Stopping stats...Done.
        Stopping mta...Done.
        Stopping spell...Done.
        Stopping snmp...Done.
        Stopping cbpolicyd...Done.
        Stopping archiving...Done.
        Stopping opendkim...Done.
        Stopping amavis...Done.
        Stopping antivirus...Done.
        Stopping antispam...Done.
        Stopping proxy...Done.
        Stopping memcached...Done.
        Stopping mailbox...Done.
        Stopping logger...Done.
        Stopping dnscache...Done.
        Stopping ldap...Done.
Host mysarana.com
        Starting ldap...Done.
Failed.
Failed to start slapd.  Attempting debug start to determine error.



zimbra@mail:/home/mysarana$

do you've check also file /etc/hosts ?


Code: Select all

127.0.0.1       localhost.localdomain   localhost
101.255.4.186   mail.mysarana.com       mail

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


This is the current /etc/hosts I use

I move the thread to here for the detailed information viewtopic.php?f=15&t=67851&p=296172#p296172

Sincerely,
Jason.