Page 1 of 1

Delete Relay Shipping

Posted: Fri Jun 26, 2020 4:42 pm
by elderf
Hello, set up a demo of mailchannels to test in zimbra but it does not adapt to what we are looking for for price reasons.

How should I make zimbra stop sending from the relay and continue sending with its normal ip as it did before configuring the relay?

I appreciate the help

Re: Delete Relay Shipping

Posted: Sat Jun 27, 2020 5:13 am
by fs.schmidt
Hello,

You need to remove the relay in "Relay MTA for external delivery" (check in global setting and in the server configuratin as well):

Re: Delete Relay Shipping

Posted: Mon Jun 29, 2020 2:20 pm
by elderf
Thanks for your help and response ...

I installed the relay by command ... not by web administration ...

And that field that you show me in the photo does not appear in the configuration via web

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 2:57 am
by fs.schmidt
elderf wrote:I installed the relay by command ... not by web administration ...


What command did you use to configure the relay?

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 12:49 pm
by elderf
su zimbra

his zimbra
1. zmprov ms mail.domain.com zimbraMtaRelayHost smtp.mailchannels.net

2. echo smtp.mailchannels.net user: passwordmailchannels> / opt / zimbra / conf / relay_password

3. postmap / opt / zimbra / conf / relay_password

is verified with this command:

postmap -q smtp.mailchannels.net / opt / zimbra / conf / relay_password

4. zmprov ms mail.domain.com zimbraMtaSmtpSaslPasswordMaps lmdb: / opt / zimbra / conf / relay_password

5. zmprov ms mail.dominio.com zimbraMtaSmtpSaslAuthEnable yes

and we end with:

zmlocalconfig -e postfix_smtp_sasl_auth_enable = yes

zmlocalconfig -e postfix_smtp_sasl_security_options = noanonymous

zmlocalconfig -e postfix_smtp_use_tls = yes

zmlocalconfig -e postfix_smtp_tls_security_level = encrypt

zmlocalconfig -e postfix_smtp_tls_note_starttls_offer = yes

zmlocalconfig -e postfix_smtp_sasl_authentication_filter =


We confirm with this:

zmprov ms mail.dominio.com zimbraMtaSmtpSaslAuthEnable yes
zmprov ms mail.dominio.com zimbraMtaSmtpCnameOverridesServername no
zmprov ms mail.domain.com zimbraMtaSmtpTlsSecurityLevel may
zmprov ms mail.dominio.com zimbraMtaSmtpSaslSecurityOptions noanonymous
zmprov ms mail.dominio.com zimbraMtaRelayHost smtp.mailchannels.net

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 12:53 pm
by phoenix
elderf wrote:su zimbra
For future reference, that command is incorrect. You should always use the hyphen to create ther correct user environment:

Code: Select all

su - zimbra

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 12:57 pm
by elderf
Hello ... the commands I use are not incorrect ... the relay was installed perfectly and works normally ...

The problem that I have and for which I consult this appreciated community is that I need to remove the relay and that the zimbra server sends with its normal IP ...

It is a normal query related to the operation of zimbra which I hope to solve ...

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 1:33 pm
by phoenix
elderf wrote:Hello ... the commands I use are not incorrect ... the relay was installed perfectly and works normally ...
I wasn't commenting on the commands, I was commenting on your misuse of the "su" command.

Re: Delete Relay Shipping

Posted: Tue Jun 30, 2020 7:03 pm
by fs.schmidt
Hi,

You can remove the relay with this command:

Code: Select all

zmprov ms mail.domain.com zimbraMtaRelayHost ""


This will remove the configuration and you just have to wait a few minutes that the service will be reloaded.

Re: Delete Relay Shipping

Posted: Wed Jul 01, 2020 10:54 pm
by elderf
fs.schmidt wrote:Hi,

You can remove the relay with this command:

Code: Select all

zmprov ms mail.domain.com zimbraMtaRelayHost ""


This will remove the configuration and you just have to wait a few minutes that the service will be reloaded.




Excellent

Thank you very much for your help ... it was exactly what I was looking for to stop sending through the relay ...

Execute the command restart the zimbra services and perform a test and the emails are sent with the assigned IP on the server.

Very grateful for your help ..

I take the issue for granted