ZCS 7 Appliance mail in queues

Running our Appliance (ZCA), ZCS on VMware, or any other virtual machine software? Post your thoughts here.
shendrickson10
Posts: 6
Joined: Sat Sep 13, 2014 1:34 am

ZCS 7 Appliance mail in queues

Postby shendrickson10 » Thu Mar 24, 2011 1:44 pm

I'm having difficulties getting my Beta appliance to receive emails. I see in the logs that the emails get into the queues and they are marked active. Yet I never get any delilvered. My Appliance is located in the DMZ. Would I need to setup split-DNS? I'm confused because if the email in the queue shouldn't I be able to see it? Thank you for any advice.


phoenix
Ambassador
Ambassador
Posts: 26329
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

ZCS 7 Appliance mail in queues

Postby phoenix » Thu Mar 24, 2011 2:08 pm

You should see from the log files whether the mail is deferred, or not. If you are behind a NAT router then you will need a Split DNS set-up.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
shendrickson10
Posts: 6
Joined: Sat Sep 13, 2014 1:34 am

ZCS 7 Appliance mail in queues

Postby shendrickson10 » Thu Mar 24, 2011 2:16 pm

Thanks, the only thing I see is "(queue active)" What other entries should I see? Will is indicate delivered or something? I'm just confused on why if the email is in the queue on the appliance, why it's not being delivered. Why would Split-DNS help? To me the email is already on the server, right?
phoenix
Ambassador
Ambassador
Posts: 26329
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

ZCS 7 Appliance mail in queues

Postby phoenix » Thu Mar 24, 2011 2:21 pm

[quote user="shendrickson10"]Thanks, the only thing I see is "(queue active)" What other entries should I see? Will is indicate delivered or something? I'm just confused on why if the email is in the queue on the appliance, why it's not being delivered. Why would Split-DNS help? To me the email is already on the server, right?[/QUOTE]Zimbra (actually it's a Postfix requirement) needs to do a DNS lookup for the IP address of the server, if you don't have that then the mail will sit in the deferred queue and not get delivered to the user mailbox.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
shendrickson10
Posts: 6
Joined: Sat Sep 13, 2014 1:34 am

ZCS 7 Appliance mail in queues

Postby shendrickson10 » Thu Mar 24, 2011 2:23 pm

Thanks, I'll setup the split-dns according to the wiki. Does that mean I need to add another network interface too?
phoenix
Ambassador
Ambassador
Posts: 26329
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

ZCS 7 Appliance mail in queues

Postby phoenix » Thu Mar 24, 2011 2:28 pm

[quote user="shendrickson10"]Thanks, I'll setup the split-dns according to the wiki. Does that mean I need to add another network interface too?[/QUOTE]If you're setting up the DNS on the Appliance then no, you don't need another interface - BIND will listen on the loopback and whatever IP it's got.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
shendrickson10
Posts: 6
Joined: Sat Sep 13, 2014 1:34 am

ZCS 7 Appliance mail in queues

Postby shendrickson10 » Thu Mar 24, 2011 2:30 pm

Understood, thank you. Have to done this on version 7 of the appliance? I ask because the wiki I'm looking says install bind9 and the appliance I have says it doesn't have bind9 but something called dnsutils. Sound familiar? Thanks.
phoenix
Ambassador
Ambassador
Posts: 26329
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

ZCS 7 Appliance mail in queues

Postby phoenix » Thu Mar 24, 2011 3:18 pm

[quote user="shendrickson10"]Understood, thank you. Have to done this on version 7 of the appliance? I ask because the wiki I'm looking says install bind9 and the appliance I have says it doesn't have bind9 but something called dnsutils. Sound familiar? Thanks.[/QUOTE]If you have another DNS server or machine on your LAN you could install BIND on that and point the A & MX records to your appliance.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
dinho
Posts: 34
Joined: Sat Sep 13, 2014 1:57 am

ZCS 7 Appliance mail in queues

Postby dinho » Fri Apr 15, 2011 12:04 pm

Configure your / etc / resolv.conf (insert in it your dns / gateway)
on your linux server

Adds the default route for your network card:
route add default gw 192.168.0.254 / / (your IP network gateway)


zimbra in global settings>>> mta>>> put your smtp in all fields (smtp.domain.com).
desmacar is optional (Enable dns queries)
Now if the mistake is authentication:
1 - zmprov ms SERVERNAME zimbraMtaRelayHost SMTP.YOURDOMAIN.COM
2 - postmap hash: / opt / zimbra / conf / relay_password
3 - SMTP.YOURDOMAIN.COM postmap-q / opt / zimbra / conf / relay_password
4 - smtp_sasl_password_maps postconf-e = hash: / opt / zimbra / conf / relay_password
5 - postconf-e smtp_sasl_auth_enable = yes
6 - postconf-e smtp_cname_overrides_servername = no
7 - postfix reload
8 - postconf-e smtp_use_tls = yes
9 - postfix reload
10 - postconf-e = debug_peer_list SMTP.YOURDOMAIN.COM

postconf-e debug_peer_level = 3
11 - postfix reload
REBOOT!
Here it works like a charm!
dinho
Posts: 34
Joined: Sat Sep 13, 2014 1:57 am

ZCS 7 Appliance mail in queues

Postby dinho » Fri Apr 15, 2011 12:07 pm

To better visualize the reason for the line, connecting via ssh
1 - su zimbra

2 - tail-f / var / log / zimbra.log
Send an email and see the island and the reason for the departure queue.

So we know where the problem lies.
Dinho.

Return to “Virtualization”

Who is online

Users browsing this forum: No registered users and 2 guests