Page 1 of 1

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 1:44 pm
by shendrickson10
I'm having difficulties getting my Beta appliance to receive emails. I see in the logs that the emails get into the queues and they are marked active. Yet I never get any delilvered. My Appliance is located in the DMZ. Would I need to setup split-DNS? I'm confused because if the email in the queue shouldn't I be able to see it? Thank you for any advice.

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:08 pm
by phoenix
You should see from the log files whether the mail is deferred, or not. If you are behind a NAT router then you will need a Split DNS set-up.

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:16 pm
by shendrickson10
Thanks, the only thing I see is "(queue active)" What other entries should I see? Will is indicate delivered or something? I'm just confused on why if the email is in the queue on the appliance, why it's not being delivered. Why would Split-DNS help? To me the email is already on the server, right?

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:21 pm
by phoenix
[quote user="shendrickson10"]Thanks, the only thing I see is "(queue active)" What other entries should I see? Will is indicate delivered or something? I'm just confused on why if the email is in the queue on the appliance, why it's not being delivered. Why would Split-DNS help? To me the email is already on the server, right?[/QUOTE]Zimbra (actually it's a Postfix requirement) needs to do a DNS lookup for the IP address of the server, if you don't have that then the mail will sit in the deferred queue and not get delivered to the user mailbox.

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:23 pm
by shendrickson10
Thanks, I'll setup the split-dns according to the wiki. Does that mean I need to add another network interface too?

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:28 pm
by phoenix
[quote user="shendrickson10"]Thanks, I'll setup the split-dns according to the wiki. Does that mean I need to add another network interface too?[/QUOTE]If you're setting up the DNS on the Appliance then no, you don't need another interface - BIND will listen on the loopback and whatever IP it's got.

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 2:30 pm
by shendrickson10
Understood, thank you. Have to done this on version 7 of the appliance? I ask because the wiki I'm looking says install bind9 and the appliance I have says it doesn't have bind9 but something called dnsutils. Sound familiar? Thanks.

ZCS 7 Appliance mail in queues

Posted: Thu Mar 24, 2011 3:18 pm
by phoenix
[quote user="shendrickson10"]Understood, thank you. Have to done this on version 7 of the appliance? I ask because the wiki I'm looking says install bind9 and the appliance I have says it doesn't have bind9 but something called dnsutils. Sound familiar? Thanks.[/QUOTE]If you have another DNS server or machine on your LAN you could install BIND on that and point the A & MX records to your appliance.

ZCS 7 Appliance mail in queues

Posted: Fri Apr 15, 2011 12:04 pm
by dinho
Configure your / etc / resolv.conf (insert in it your dns / gateway)
on your linux server

Adds the default route for your network card:
route add default gw 192.168.0.254 / / (your IP network gateway)


zimbra in global settings>>> mta>>> put your smtp in all fields (smtp.domain.com).
desmacar is optional (Enable dns queries)
Now if the mistake is authentication:
1 - zmprov ms SERVERNAME zimbraMtaRelayHost SMTP.YOURDOMAIN.COM
2 - postmap hash: / opt / zimbra / conf / relay_password
3 - SMTP.YOURDOMAIN.COM postmap-q / opt / zimbra / conf / relay_password
4 - smtp_sasl_password_maps postconf-e = hash: / opt / zimbra / conf / relay_password
5 - postconf-e smtp_sasl_auth_enable = yes
6 - postconf-e smtp_cname_overrides_servername = no
7 - postfix reload
8 - postconf-e smtp_use_tls = yes
9 - postfix reload
10 - postconf-e = debug_peer_list SMTP.YOURDOMAIN.COM

postconf-e debug_peer_level = 3
11 - postfix reload
REBOOT!
Here it works like a charm!

ZCS 7 Appliance mail in queues

Posted: Fri Apr 15, 2011 12:07 pm
by dinho
To better visualize the reason for the line, connecting via ssh
1 - su zimbra

2 - tail-f / var / log / zimbra.log
Send an email and see the island and the reason for the departure queue.

So we know where the problem lies.
Dinho.