zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

Running our Appliance (ZCA), ZCS on VMware, or any other virtual machine software? Post your thoughts here.
pete irvine
Posts: 47
Joined: Sat Sep 13, 2014 1:59 am

zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

Postby pete irvine » Wed May 25, 2011 4:14 pm

Anyway to get this limit lifted to a reasonable number like 5GB. Have 4 mailboxes to import over 2GB.

Will look into it myself and post solution when I find it


pete irvine
Posts: 47
Joined: Sat Sep 13, 2014 1:59 am

zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

Postby pete irvine » Wed May 25, 2011 5:11 pm

Tried the "curl" import.

What a pain.

Curl is not in the path on appliance 6.0.13.406 so had to use :

sudo find / -name curl -print|more to locate it

rephrased command line with full path to curl...

sudo /path/curl -k -u admin:PASSWORD --data-binary @/path/to/USER-account.tgz https://MAILSTORE-FQDN:7071/service/home/USER@DOMAIN/?fmt=tgz&resolve=skip"

and got the response

curl option --data-binary out of memory.

Now shutting down domain controller and firewall VM's so can allocate all the memory on the box to the mail server for the duration of the import....

Maybe an import facility that worked would be a valuable addition to zimbra - perhaps a documented one would be even better.

Will advise results.
pete irvine
Posts: 47
Joined: Sat Sep 13, 2014 1:59 am

zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

Postby pete irvine » Wed May 25, 2011 5:38 pm

Is there a way to import the tgz files that does not send it via the webserver - perhaps a perl script that sends it straight to the database ???

The import failed again after consuming 6.8GB of RAM for a 1.9GB file !

Yet again hitting a limit on the webserver get error :

form too large 1984502028&gt 200000

Going back to searching for the answer will post results
pete irvine
Posts: 47
Joined: Sat Sep 13, 2014 1:59 am

zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

Postby pete irvine » Thu May 26, 2011 8:57 pm

I allocated 12GB of RAM and 3 vCPU's and used :

zmmailbox to import.

Also updated php.ini -> not sure if it was nessesary but was part of what I did :

Settings changed :

memory_limit=64M (Defaults to 8M)

post_max_size=8196M (Default is 2M ?)

upload_max_file_size=8196M (Default is 2M ?)
If I do this again I'll try without PHP.INI changes above - can someone test this perhaps ?
NOTE: In the appliance zmmailbox is not in the path {/opt/zimbra/bin/zmmailbox}

The full line is :

sudo /opt/zimbra/bin/zmmailbox -z -m user@domain pru "//?fmt=tgz&resolve=skip" {path to tgz file}.
NOTE: Appliance does not have room in /tmp for large files so I created a directory /opt/zimbra/tmp, chown vmware:vmware and chmod 777 then used ftp to move the file into this dir.
I hope this helps someone...........

Return to “Virtualization”

Who is online

Users browsing this forum: No registered users and 2 guests