[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Running our Appliance (ZCA), ZCS on VMware, or any other virtual machine software? Post your thoughts here.
lespaul20
Posts: 16
Joined: Sat Sep 13, 2014 1:20 am

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby lespaul20 » Wed Jun 29, 2011 8:38 am

I attempted to install the recently released patch for 7.1.1 on a system just updated to Release 7.1.1_GA_3196.RHEL5_64_20110527001604 RHEL5_64 NETWORK edition but I received this error:
perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/a

uto/Cwd/Cwd.so: undefined symbol: Perl_Gthr_key_ptr
Any ideas on what's causing it and how to solve it?
I manged to post this in the wrong forum. Please move.


7531prashant
Outstanding Member
Outstanding Member
Posts: 343
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby 7531prashant » Wed Jun 29, 2011 2:55 pm

I do not see this problem with 7.1.1 latest patch installation.
It seems that the version of perl was upgraded w/ the new distro and new version seems to be incompatible with old.
lespaul20
Posts: 16
Joined: Sat Sep 13, 2014 1:20 am

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby lespaul20 » Wed Jun 29, 2011 3:28 pm

So would upgrading perl solve this?
7531prashant
Outstanding Member
Outstanding Member
Posts: 343
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby 7531prashant » Wed Jun 29, 2011 3:52 pm

What is the perl version you are having?
7531prashant
Outstanding Member
Outstanding Member
Posts: 343
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby 7531prashant » Wed Jun 29, 2011 3:55 pm

[zimbra@domain ~]$ perl -v
This is perl, v5.8.8 built for x86_64-linux-thread-multi
lespaul20
Posts: 16
Joined: Sat Sep 13, 2014 1:20 am

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby lespaul20 » Wed Jun 29, 2011 4:01 pm

perl -v
This is perl 5, version 12, subversion 1 (v5.12.1) built for x86_64-linux

I think this is my problem.
phoenix
Ambassador
Ambassador
Posts: 26326
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby phoenix » Thu Jun 30, 2011 12:47 am

[quote user="lespaul20"]perl -v
This is perl 5, version 12, subversion 1 (v5.12.1) built for x86_64-linux
I think this is my problem.[/QUOTE]That's the most likely reason. Where did you get that version from?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
7531prashant
Outstanding Member
Outstanding Member
Posts: 343
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby 7531prashant » Thu Jun 30, 2011 12:48 am

Yeah it seems...give a try with 5.8.8.
lespaul20
Posts: 16
Joined: Sat Sep 13, 2014 1:20 am

[SOLVED] Perl: symbol lookup error - ZCS Patch 7.1.1

Postby lespaul20 » Thu Jun 30, 2011 2:21 pm

[quote user="10330phoenix"]That's the most likely reason. Where did you get that version from?[/QUOTE]
It was the reason. I'm not sure where it came from, it was installed in /usr/local/bin and since it's before /usr/bin in the path it was causing the problem.
Thanks for the help.

Return to “Virtualization”

Who is online

Users browsing this forum: No registered users and 3 guests