Page 1 of 1

Docker

Posted: Thu Dec 01, 2016 3:48 pm
by erwin
Hello,
I'm trying to create a Docker image of the Zimbra open source version.
I've already had a success creating such image and it can be deployed as a docker container. But I have some small issues.
If anyone wants to try it out and contribute, she or he is welcome to.

https://github.com/devent/zimbra_docker

Docker Image

https://hub.docker.com/r/erwinnttdata/zimbra/

What is it good for?
- easy of deployment
- easy of updating
- resources limitation
But mostly:
- deployment as Kubernetes pod.
- even deployment on OpenShift.

Currently, I want to fix the issue that the administrator site shows that the services as not running despite the fact that the servers are running.
Maybe anyone have an idea?

Re: Docker

Posted: Fri Jan 06, 2017 6:49 pm
by jorgedlcruz
Hi Erwin,
Why not work on the current one?

That is working without problems, and it seems to be easiest to deploy

Best regards

Re: Docker

Posted: Mon Jul 03, 2017 2:52 pm
by asanoja
We have the same problem, using that version. Services are running but the administrator shows that they are not.

We have been trying solutions found in google, but no luck.
When starting the container, we restart all with zmcontrol they are all fine, but in the web admin interfaces they are shown down. Are they reading the pid correctly?
We have change the permissions to log files and pid files. But still, no luck.

Does anyone has a solution??.

Thanks in advance

jorgedlcruz wrote:Hi Erwin,
Why not work on the current one?

That is working without problems, and it seems to be easiest to deploy

Best regards

Re: Docker

Posted: Fri Aug 11, 2017 6:54 pm
by asanoja
asanoja wrote:We have the same problem, using that version. Services are running but the administrator shows that they are not.

We have been trying solutions found in google, but no luck.
When starting the container, we restart all with zmcontrol they are all fine, but in the web admin interfaces they are shown down. Are they reading the pid correctly?
We have change the permissions to log files and pid files. But still, no luck.

Does anyone has a solution??.

Thanks in advance

jorgedlcruz wrote:Hi Erwin,
Why not work on the current one?

That is working without problems, and it seems to be easiest to deploy

Best regards


Thanks, we are using your version, that you mentioned in the response. However, the problem persits. We have been trying restarting the logger, restarting zimbra once the container is ready and many other solutions found in forums, but still no luck.

We installed the ssh server and client in order to view the certificates, not shown before from the admin interface.

Any suggestions

Thanks in advance

Re: Docker

Posted: Thu Aug 24, 2017 1:36 am
by iomarmochtar
jorgedlcruz wrote:Hi Erwin,
Why not work on the current one?

That is working without problems, and it seems to be easiest to deploy

Best regards



Is it has been used in production and run smoothly ?

Re: Docker

Posted: Sat Aug 26, 2017 1:10 am
by jorgedlcruz
Hello,
I've been running some demo servers with it, without an issue. I will not recommend Docker for production for Zimbra, not at least all services anyways.

Best regards