Create tag bug in create new filter

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

Create tag bug in create new filter

Postby PotatoBob » Sat Oct 29, 2005 11:44 pm

I have found this annoyance, well I think its a bug and hopefully not a feature... :)
When creating a tag by right click on an email and then click create new tag it works, but when creating a tag while using the "tag with" action in the filters section it just seems to crash the zimbra client. It freezes with a white tint. (assuming server never responds?)
Heres how to duplicate it just to see if this is just me
1. login to zimbra

2. goto preferences

3. goto filter rules

4. click add

5. in "perform the following actions"

5.5 change the action to "tag with" and then click browse

6. click new tag and type in some name

7. click ok to create a new tag
My screen then just does nothing but freeze
And another thing...

Is this a feature that instead of MOVING an email from the inbox to another folder via filters it copies it to another folder? I hope it isn't because this is happening.

In the Admin panel there are a few places like accounts that the tooltips are buggy (they aren't displayed correctly)

Also would be a nice feature if we could tag a whole folder.
How would we go on making a new theme? (Not that I dont like the current steel one, I just feel too mac-ish about this steel theme)


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Create tag bug in create new filter

Postby 14319KevinH » Sun Oct 30, 2005 3:00 pm

[quote user="PotatoBob"]I have found this annoyance, well I think its a bug and hopefully not a feature... :)
When creating a tag by right click on an email and then click create new tag it works, but when creating a tag while using the "tag with" action in the filters section it just seems to crash the zimbra client. It freezes with a white tint. (assuming server never responds?)
Heres how to duplicate it just to see if this is just me
1. login to zimbra

2. goto preferences

3. goto filter rules

4. click add

5. in "perform the following actions"

5.5 change the action to "tag with" and then click browse

6. click new tag and type in some name

7. click ok to create a new tag
My screen then just does nothing but freeze

[/QUOTE]
This worked fine for me in the current code. So seems we've fixed it. Pease try this with the next build and confirm it works for you.
[quote user="PotatoBob"]

And another thing...

Is this a feature that instead of MOVING an email from the inbox to another folder via filters it copies it to another folder? I hope it isn't because this is happening.

[/QUOTE]



So your using the "file into folder" action? This should be a move.
[quote user="PotatoBob"]

In the Admin panel there are a few places like accounts that the tooltips are buggy (they aren't displayed correctly)

[/QUOTE]



The admin UI has had lots of work so this should be fixed for the next release. If you still see problems please report them.
[quote user="PotatoBob"]

Also would be a nice feature if we could tag a whole folder.

[/QUOTE]



We don't allow this in the UI since it's a pretty expensive if there are lots of messages in the folder. Our think it that if you've already got them in a folder why do you also need a tag. If you *really* need to do this you can set the page size to 100 and tag them 100 at a time.
[quote user="PotatoBob"]

How would we go on making a new theme? (Not that I dont like the current steel one, I just feel too mac-ish about this steel theme)[/QUOTE]
We've not documented this yet. If you look in the ZimbraWebClient you'll see a skins folder and the steel dir. You can start by looking at and modifying the CSS and images in there.
PotatoBob
Posts: 16
Joined: Fri Sep 12, 2014 9:59 pm

Create tag bug in create new filter

Postby PotatoBob » Sun Oct 30, 2005 9:54 pm

another thing I have noticed that if im using firefox and I goto calendar and open the dialog to create a new task while my firefox window is smaller than the dialog then the dialog is cut off even if I resize my firefox window...
maybe the dialog should resize itself or add an option to beable to scroll perhaps?
Is this fixed?

And what is the normal response time of zimbra for everyone, mine seems to be like a second off of my clicks...

3.4 ghz workstation should be sufficient
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Create tag bug in create new filter

Postby 14319KevinH » Mon Oct 31, 2005 11:16 am

The dialog is now internal in the next version. Let us know how you like it.
Depends on the operation but for me some things are sub-sec others like bug searches are not. We will be doing some performance work after the next release. We are heads down on the new features right now.

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 2 guests