Issue in Sending Multiple Attachments in a Forwarded Email

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
VistoPartner
Posts: 16
Joined: Fri Sep 12, 2014 11:56 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby VistoPartner » Thu Mar 05, 2009 7:41 pm

Hi,
I am trying to forward an email that has 2 attachments using SOAP API. Here is the SOAP msg looks like:


http://www.w3.org/2003/05/soap-envelope">





123456















FW: Test-2



Test FW


















I'm getting only the new body not the original body and also I'm not able to get the 2nd attachment. If the change attach TAG to different way as follows:










then I'm getting the original email as attachment not as in-line. If I change attach TAG as follows:










then I'm not getting the original msg, but I'm getting only the attachment which was uploaded(1234).
Could anybody please tell me what I'm doing wrong and how to forward an email with multiple attachments and in-line original body with new body?
Thanks a lot for help.

- VistoPartner.


fernandoflorez
Outstanding Member
Outstanding Member
Posts: 235
Joined: Fri Sep 12, 2014 10:15 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby fernandoflorez » Thu Mar 05, 2009 8:05 pm

Hmm... i don't understand exactly what you say about the message body but i can say that your aid for the attachment is not looking correctly.
From what i know it's a par conformed of the client token and the server token:
aid="client_token:server_token" with the ":" as a separator. For more than one attachment:
aid="client_token:server_token,client_token2:server_token2"
VistoPartner
Posts: 16
Joined: Fri Sep 12, 2014 11:56 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby VistoPartner » Thu Mar 05, 2009 9:19 pm

Thanks fernandoflorez for quick reply.
I have correct aid value actually, but here I posted for simplicity a value. The real aid="69e376e6-8f18-4b37-b284-d1271a1781ac:d0b45291-ebe3-4d26-aa8b-524069c9a16d"
I have 2 of them and I created attach TAG with 2 aid values as follows:

But I'm getting only the 1st attachment.
When I forward a email, it should appear something as follows:
From:

To:

Subject:
New text/HTML Body of the current Email
------- Original Message --------

From:

To:

Subject:
As mentioned above, the original full email should be attached as in-line text to the current email that is being forwarded.
But in my case using zimbra SOAP API, I'm not getting the bottom portion which is the original message as in-line text.
Hope this helps in clarifying the question.

Hoping to get some solution or reply.
Thaking You,

- VistoPartner.
fernandoflorez
Outstanding Member
Outstanding Member
Posts: 235
Joined: Fri Sep 12, 2014 10:15 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby fernandoflorez » Thu Mar 05, 2009 9:42 pm

zimbra server won't inject the message replied to the body. You need to do that manually.
1) GetMessageRequest

2) Format the body with the other message body

3) SendMessageRequest
No idea why you are not receiving both attachments. Have you tried a normal form to see if both attachments still exist on server?
How is your sendmessageresponse?
Thanks,
VistoPartner
Posts: 16
Joined: Fri Sep 12, 2014 11:56 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby VistoPartner » Fri Mar 06, 2009 12:38 pm

Ok, I thought zimbra will handle reply and forward, because in the SendMsgRequest we have to specify the origid for reply and forward. If zimbra doesn't support automatic appending of Original Email's body to the replied/forwarded mail's body, I don;t understand why we have to specify origid.
AS given in soap.txt:

-----------------------------------

+ on reply/forward, set origid on element and set rt to "r" or "w", respectively


origid="..." rt="r|w"] [idnt="{identity-id}"]>

------------------------------------
Thanking You,
fernandoflorez
Outstanding Member
Outstanding Member
Posts: 235
Joined: Fri Sep 12, 2014 10:15 pm

Issue in Sending Multiple Attachments in a Forwarded Email

Postby fernandoflorez » Fri Mar 06, 2009 4:25 pm

hmm... no idea but origid could be for threading? No idea.
From what i see they include the replied content on the body of the new mail.

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 2 guests