Page 1 of 1

Contact Details Empty when viewing in Zimbra Client

Posted: Mon May 11, 2009 5:46 pm
by VistoPartner
Hi All,
I created a contact using zimbra API as follows:


http://www.w3.org/2003/05/soap-envelope">">http://www.w3.org/2003/05/soap-envelope"> xmlns="urn:zimbra">123456FromDeviceDevice, FromGood2Goodtesting@testing.comother://some@something.com(425) 555-8888(425) 555-9999


Following is the response that I got from zimbra for creating this new contact,


http://www.w3.org/2003/05/soap-envelope">">http://www.w3.org/2003/05/soap-envelope"> xmlns="urn:zimbra">16913(425) 555-8888(425) 555-9999Goodother://some@something.comDevice, From2testing@testing.comFromDeviceGood


When I checked the contact using the Zimbra web client, other than Name and title, other information were completly absent. When I perform GetFullItem on this contact ID, I get complete details. But only in client I can't seem to see any information. I have attached an image also.

Any help is appreciated.
Thanks,

Zimbra_Contact_Issue.jpg


Contact Details Empty when viewing in Zimbra Client

Posted: Thu May 14, 2009 1:29 pm
by Matt Rhoades
Your request works correctly for me.
http://www.w3.org/2003/05/soap-envelope">





0_1858b303598f04dcd...272613b











AFrom

ADevice

ADevice, AFrom

AGood

2

AGood

atesting@testing.com

other://asome@something.com

(425) 555-8888

(425) 555-9999










Maybe it is a client refresh issue? What happens if you refresh the web client?

Contact Details Empty when viewing in Zimbra Client

Posted: Thu May 14, 2009 2:18 pm
by VistoPartner
Doesn't do anything. It just displays the same screen. Also, I tried with 3 other browsers and they all same behavior. Also, after I see the contact in zimbra, I logged out of the account and logged back in. Same behavior.
The ZCS version we are using is 5.0.11_GA_2695.SuSEES10.NETWORK Nov 17, 2008. Currently from the zimbra website looks like there is 5.0.16 is available. I don;t if this is an issue in 11 and I also don;t know if this is fixed in 16.

Contact Details Empty when viewing in Zimbra Client

Posted: Thu May 14, 2009 5:19 pm
by pshah
If you're using Firefox, do the following:
- load the client in debug mode (append "?dev=1" without quotes to the url).

- view the contact

- check if there are any Javascript errors in the Error Console
In the debug window, you will see a bunch of SOAP requests/responses. Check the response for GetContactsRequest and see whether all info you originally entered is being returned.
Does the format of the repsonse for the contact you created look similar to the format of contacts that do show up correctly?