Integrating Hello World Example App

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
sb0373
Posts: 18
Joined: Tue Sep 15, 2015 9:59 am

Integrating Hello World Example App

Postby sb0373 » Fri Nov 03, 2017 3:08 pm

Hello Zimbra Community and Zimbra Devs,

can you please give me some indications on how to get the sample Hello World App to work? (can be found under https://github.com/Zimbra/zm-web-client ... tom/addapp )

I am using the latest develop branch and I claim I followed all the instructions in the helloworldapp.txt:
- copied the helloworld folder into WebRoot/js/zimbraMail
- copied the HelloWorldCore.js file into WebRoot/js/zimbraMail/package
- Updated the App load code in WebRoot/js/zimbraMail/package/Startupp1_2.js (and tripple verified the line)
- Added the localisation strings to WebRoot/messages/ZmMsg.properties
- [ also the remaining files were edited as of the instructions even though as far as I understand, this is not necessary at all any more ]
- ant prod-deploy (all finished successfully)

Now when I load the Advanced client, it shows no difference to the original application. Nothing has changed. I tried to figure out where the issue is but could not pinpoint it or even figure out if anything was loading or failing. Any hints how to do that?

I added alert("I am here"); to all the StartUp* files but the alert actually never pops up so it seems either alert does not work or none of the js scripts are loaded.

Is there a different way to register new applications?

Thank you for any indications.

Best wishes,

Stefan

PS: I am just trying to play around and understand the framework a lot better. Maybe I will add new pages into my Zimbra copy in future.
Last edited by sb0373 on Fri Nov 03, 2017 7:57 pm, edited 1 time in total.


sb0373
Posts: 18
Joined: Tue Sep 15, 2015 9:59 am

Re: Integrating Hello World Example App

Postby sb0373 » Fri Nov 03, 2017 6:52 pm

ok, quick update from my side:
1) there was a caching "issue". Now the JavaScript alerts do pop up.
2) The call AjxPackage.require("zimbraMail.helloworld.ZmHelloWorldApp"); in Startup1_2.js seems to be failing
3) The browser shows a 404 error on localhost:8443/js/zimbraMail/helloworld/ZmHelloWorldApp_all.js.zgz

At least now I found a few more pointers where to look at. This seems to me like a build error somewhere

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 5 guests