Faulty JSON response for SendMsgResponse

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
parin
Posts: 28
Joined: Sat Sep 13, 2014 3:06 am

Faulty JSON response for SendMsgResponse

Postby parin » Tue Dec 03, 2013 6:25 am

Hi,
according to soap structure for SendMsgResponse the response should be,
## SendMsgResponse

## Id


but what i am getting in JSON response is,something like this.
{"SendMsgResponse":{"m":[{"id":"2425"}],"_jsns":"urn:zimbraMail"}},"_jsns":"urn:zimbraSoap"}
note that [ and ]. there should be no squre braces in m tag. this is same issue like http://www.zimbra.com/forums/developers/66523-strange-json-response-authrequest.html. i request moderators as well as active developer to check this issue and raise a bug if it is a bug.
Thank You.
Parin Dholakia,

India.


gren
Zimbra Employee
Zimbra Employee
Posts: 39
Joined: Sat Sep 13, 2014 1:23 am

Faulty JSON response for SendMsgResponse

Postby gren » Wed Dec 04, 2013 6:00 am

Hi Parin,

This issue has the same root cause as for AuthRequest - I've updated Bug 85110 ? JAXB/Documentation for SOAP AuthResponse is incorrect - authToken is an array, not a singleton to mention it.

Thanks,

Gren
parin
Posts: 28
Joined: Sat Sep 13, 2014 3:06 am

Faulty JSON response for SendMsgResponse

Postby parin » Sun Dec 08, 2013 11:35 pm

Thank you @gren.
parin
Posts: 28
Joined: Sat Sep 13, 2014 3:06 am

Faulty JSON response for SendMsgResponse

Postby parin » Mon Dec 09, 2013 1:24 am

@Gren
Hi,
i discoverd same issue in SaveDraftResponse as well. so i think the API documentation should be reassessed !. please report it.
Thank You.

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 6 guests