MsgActionRequest not working for certain messages

Have a great idea for extending Zimbra? Share ideas, ask questions, contribute, and get feedback.
DocRockulus
Posts: 3
Joined: Thu Sep 17, 2020 3:15 pm

MsgActionRequest not working for certain messages

Postby DocRockulus » Mon Sep 28, 2020 8:00 pm

I'm making a simple request to move a message to another directory:

Code: Select all

    move_request.add_request(
        'MsgActionRequest',
            {
                'action': {
                    'id': id,
                    'op': 'move',
                    'l': destination_folder_id
            }
        },
    'urn:zimbraMail'
    )

and this request works for the majority of messages, the response given is:

Code: Select all

{'MsgActionResponse': {'action': {'id': '5581', 'op': 'move'}}}

However for a certain group of messages (35 specifically in my inbox) the message is never actually moved to the new directory. The response from the server matches that of other successfuly moved items, but again, no change is visible in the inbox.
Is there a way I can determine what specifically is causing these messages to fail to be moved to a different directory? Are there some kind of tag on the message that could cause this type of behavior?


User avatar
jeastman
Zimbra Employee
Zimbra Employee
Posts: 33
Joined: Tue Mar 29, 2016 1:36 pm

Re: MsgActionRequest not working for certain messages

Postby jeastman » Tue Sep 29, 2020 6:36 pm

You may want to check via API where the messages actually exist after your attempted move.

If you have conversation view turned on in the UI, messages not physically in the Inbox may appear in the UI Inbox if they are associated with other messages.
John Eastman

Return to “Developers”

Who is online

Users browsing this forum: No registered users and 3 guests