Zimlets fails to initialize on Zimbra 8.0.6

Interested in talking about Mash-up's? This is the place.
krabina
Advanced member
Advanced member
Posts: 165
Joined: Fri Sep 12, 2014 11:53 pm

Zimlets fails to initialize on Zimbra 8.0.6

Postby krabina » Mon Jan 13, 2014 3:23 am

Hi,

after upgrade to Zimbra 8, Zimlets fails to initialize with the error message "TypeError: this.handlerObject._init is not a function ".
tried the social zimlet and blogstosignature. no matter what zimlet I activate, I get this message
What's wrong?

regards,

Bernhard


krabina
Advanced member
Advanced member
Posts: 165
Joined: Fri Sep 12, 2014 11:53 pm

Zimlets fails to initialize on Zimbra 8.0.6

Postby krabina » Mon Jan 13, 2014 4:10 am

I undeployed almost every Zimlet, now it works...
8228cdamon
Advanced member
Advanced member
Posts: 52
Joined: Fri Sep 12, 2014 9:55 pm

Zimlets fails to initialize on Zimbra 8.0.6

Postby 8228cdamon » Mon Jan 13, 2014 6:45 pm

One thing to try is to load with ?dev=1 at the end of the URL. That should cause a debug window to be opened.

Then load and look in the debug window for something like this:
ERROR - Zimlet handler ...
krabina
Advanced member
Advanced member
Posts: 165
Joined: Fri Sep 12, 2014 11:53 pm

Zimlets fails to initialize on Zimbra 8.0.6

Postby krabina » Mon Jan 20, 2014 7:31 am

Die initialization now works, but the social zimlet seems to be broken. The twitter functionality seems to still use the old api: "The Twitter REST API v1 is no longer active. Please migrate to API v1.1.
Trying">https://dev.twitter.com/docs/api/1.1/overview."
Trying
to add a facebook account results in a not found error: "zimbraoauth2support.cloudfoundry.com"

Return to “Zimlets”

Who is online

Users browsing this forum: No registered users and 4 guests