Problem reenabling zimlets

Interested in talking about Mash-up's? This is the place.
1339darwinian
Posts: 4
Joined: Fri Sep 12, 2014 10:05 pm

Problem reenabling zimlets

Postby 1339darwinian » Wed Feb 22, 2006 1:47 pm

Hi all,

I'm trying to get a better understanding of zimlets and how they're deployed in Zimbra; I disabled all the zimlets in the distribution using the command line (to have a clean environment for zimlet creation). I am now trying to reactivate all zimlets again... but some refuse to appear. The wikipedia zimlet panel item doesnt' reappear, even when re-enabled (according to listZimlets). Also, the "search" zimlet panel item reappears, but doesnt do anything when clicked.
Also, how does the tag work? Mousing over on top of panel items doesn't yield the expected tooltip even with the tags in place.
Thanks


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Problem reenabling zimlets

Postby 14319KevinH » Wed Feb 22, 2006 3:55 pm

Move to new Zimlet's Forum...
Are you restarting after turning on/off zimlets? We cache the COS data so you'll need to bounce tomcat to clear that. You'll also then need to login again so your user will load the latest Zimlet list.
The search Zimlet doesn't have a single-click action. Just a right-click action to bring up a menu of search options.
Tooltip was not being passed to the UI in the current release. It's fixed in our mainline so that will be working in a upcoming release. Feel free to put some text in there on your Zimlets, since it will show-up once you upgrade.
outdated
Posts: 9
Joined: Fri Sep 12, 2014 10:04 pm

Problem reenabling zimlets

Postby outdated » Thu Feb 23, 2006 12:52 am

I've managed to redeploy zimlets but did see a couple of issues that I'd like to share:
1) Once a zimlet is deployed, you cannot undeploy and then redeploy it (they should be symmetrical operations, right?).

$ zmzimletctl deploy com_my_zimlet.zip

INFO: Installing ...

$ zmzimletctl undeploy com_my_zimlet

INFO: Uninstalling...

INFO: Removing ...

$ tomcat restart

...

$ zmzimletctl deploy com_my_zimlet.zip

...

Error: cannot update Zimlet config for com_my_zimlet : system failure: unable to modify attrs

To re-deploy, I had to re-grant the acl, then enable the zimlet, and finally re-deploy it.
2) zmzimletctl uninstall isn't listed in the zmzimletctl help.
On to some development for me!
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Problem reenabling zimlets

Postby 14319KevinH » Thu Feb 23, 2006 9:33 am

1) Did you increase the version in the .xml file?
2) Can you file a bug in http://bugzilla.zimbra.com ?
outdated
Posts: 9
Joined: Fri Sep 12, 2014 10:04 pm

Problem reenabling zimlets

Postby outdated » Thu Feb 23, 2006 11:08 am

1. I didn't increase the version # in my original attempts. After increasing it, I got the same result.
2. Created bug 6182
Forgot to mention this is on 3.0.1 in my original post.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Problem reenabling zimlets

Postby 14319KevinH » Thu Feb 23, 2006 11:40 am

1) Did you try to just bump the version and call deploy again? This is how I install mine via some ANT short cuts I've got in the build.xml file.
outdated
Posts: 9
Joined: Fri Sep 12, 2014 10:04 pm

Problem reenabling zimlets

Postby outdated » Thu Feb 23, 2006 10:30 pm

Thanks for the tip. Now I see the INFO: Upgrading Zimlet to msg after deploying it, which is reassuring.
That is really what I needed--the ability to test zimlet updates easily. I did notice though that panel updates (simply changed the name) don't seem to happen after bumping the version. If it happens again, I'll post a msg.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Problem reenabling zimlets

Postby 14319KevinH » Fri Feb 24, 2006 12:16 am

You still may need a tomcat restart in there for some things that are cached.

Return to “Zimlets”

Who is online

Users browsing this forum: No registered users and 2 guests