[SOLVED] "The Open Chat Zimlet needs to be updated!" Popup

Interested in talking about Mash-up's? This is the place.
dparker
Posts: 4
Joined: Wed Dec 06, 2017 4:34 pm
ZCS/ZD Version: 8.8.10.GA.3039.UBUNTU16.64

[SOLVED] "The Open Chat Zimlet needs to be updated!" Popup

Postby dparker » Wed Dec 06, 2017 4:46 pm

I have a ZCS Open Source install version 8.7.11_GA_1854 (build 20170531151956) running on Ubuntu 16.04. Yesterday, users have been getting the following popup upon logging in. How can I update the chat zimlet?

The Open Chat Zimlet needs to be updated!
Current ZxChat Zimlet version: 8.7.10
Needed ZxChat Zimlet version: 8.8.4


Image


User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

Re: "The Open Chat Zimlet needs to be updated!" Popup

Postby jorgedlcruz » Wed Dec 06, 2017 9:58 pm

Hello,
Yeah, my apologies for it, it seems we have updated the repository and add a new Chat zimlet, so you need to deploy it manually, it's simple as zimbra user:

Code: Select all

zmzimletctl deploy /opt/zimbra/zimlets/com_zextras_chat_open.zip
[] INFO: Deploying Zimlet com_zextras_chat_open in LDAP.
[] INFO: Installing Zimlet com_zextras_chat_open on this host.
[] INFO: Upgrading Zimlet com_zextras_chat_open to 16.44.0
[] INFO: Adding Zimlet com_zextras_chat_open to COS default
[] INFO: Enabling Zimlet com_zextras_chat_open

Then:

Code: Select all

zmprov fc all

And finally:

Code: Select all

zmmailboxdctl restart


I'm writing a wiki and adding a warning into the main forums category/notification, sorry!
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

Re: "The Open Chat Zimlet needs to be updated!" Popup

Postby jorgedlcruz » Wed Dec 06, 2017 10:09 pm

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
dparker
Posts: 4
Joined: Wed Dec 06, 2017 4:34 pm
ZCS/ZD Version: 8.8.10.GA.3039.UBUNTU16.64

Re: [SOLVED] "The Open Chat Zimlet needs to be updated!" Popup

Postby dparker » Thu Dec 07, 2017 5:52 pm

That did the trick! Thank you!
User avatar
alebeta
Posts: 11
Joined: Tue Jan 08, 2019 5:22 pm
Contact:

Re: "The Open Chat Zimlet needs to be updated!" Popup

Postby alebeta » Sat Feb 16, 2019 1:55 pm




Hi Jorge,

what is good to do when using command:

Code: Select all

zmprov fc all


we get this output:

Code: Select all

ERROR: service.INVALID_REQUEST (invalid request: can only be used with SOAP)


thanks and all the best

Return to “Zimlets”

Who is online

Users browsing this forum: No registered users and 2 guests