Kernel Panic

Post feedback about our hosted demo or your local install. Tell us what you love and/or what you’d like to see added in the future.
10441andywan
Posts: 4
Joined: Fri Sep 12, 2014 10:05 pm

Kernel Panic

Postby 10441andywan » Fri Feb 24, 2006 5:00 am

I've recently just installed Zimbra 3.0.1 on a fresh Fedora Core 4 install, and works fine, apart from being very slow at times, however I think this is due to the fact that I'm running this inside a VMWare server. I've assigned 1Gb ram to it, and a 10Gb partition for testing purposes.
The problem I see is that something appears to use up all of the memory on the box, and I see kernel messages displayed on the screen saying it's killing processes to make more memory, and finally dies when there's no more spare processes for it to kill. Reboot, and it comes back to normal, until it next occurs.
I've only had this installed for a day, but I've been able to reproduce this on two occasions now. I don't seem to need to put much load on the server either - I left the VM up overnight, came in in the morning and ran 'zmcontrol status' as user zimbra and it sat there doing nothing. A couple of minutes later I noticed the kernel messages being thrown up on the screen, and then locked.
Unfortunately, I don't have a copy of the messages here, but if anyone's interested, I could try to reproduce it and post what I see?


Apart from this though, it seems like a great piece of software! :)


14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Kernel Panic

Postby 14319KevinH » Fri Feb 24, 2006 10:25 am

VMWare is not a good way to run a server. It's perfect for checking things out and playing, but not for any type of real system. It's just too unstable and performance limiting. It's pretty easy to get a VM locked up with complex software like Zimbra. If you want a stable system just install Linux.
andreychek
Advanced member
Advanced member
Posts: 155
Joined: Fri Sep 12, 2014 9:58 pm

Kernel Panic

Postby andreychek » Fri Feb 24, 2006 1:00 pm

[quote user="10441andywan"]The problem I see is that something appears to use up all of the memory on the box, and I see kernel messages displayed on the screen saying it's killing processes to make more memory, and finally dies when there's no more spare processes for it to kill. Reboot, and it comes back to normal, until it next occurs[/QUOTE]

Yeah, it's unfortunate that you're running into that, but I agree with Kevin that I think vmware is the culprit, moreso than the OS or Zimbra.
I have a test server setup where I can screw around with all the settings and otherwise break things without users complaining... and it's running on a dual 600Mhz box with 386MB of RAM with no problems at all (other than a long load time, but that's to be expected on a box like that :-)
If you wish to pursue running it in VMware, I'd also make sure you have plenty of swap setup. Under VMware, it'll be dog slow once it starts doing any significant swaping, but it in theory should at least work.
Have a good one,

-Eric
marcmac
Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Kernel Panic

Postby marcmac » Fri Feb 24, 2006 1:12 pm

does /etc/sysconfig/i18n have any utf8 references in it?
If so, remove them (search the forums) and reboot.
retireoncsco
Posts: 24
Joined: Fri Sep 12, 2014 10:02 pm

Kernel Panic

Postby retireoncsco » Sat Feb 25, 2006 12:31 am

[quote user="10441andywan"]
The problem I see is that something appears to use up all of the memory on the box, and I see kernel messages displayed on the screen saying it's killing processes to make more memory, and finally dies when there's no more spare processes for it to kill. Reboot, and it comes back to normal, until it next occurs.
I've only had this installed for a day, but I've been able to reproduce this on two occasions now. I don't seem to need to put much load on the server either - I left the VM up overnight, came in in the morning and ran 'zmcontrol status' as user zimbra and it sat there doing nothing. A couple of minutes later I noticed the kernel messages being thrown up on the screen, and then locked.

[/QUOTE]
Dump FC and go with CentOS4.2 is much better under VMWare.
10441andywan
Posts: 4
Joined: Fri Sep 12, 2014 10:05 pm

Kernel Panic

Postby 10441andywan » Mon Feb 27, 2006 4:17 am

[quote user="marcmac"]does /etc/sysconfig/i18n have any utf8 references in it?
If so, remove them (search the forums) and reboot.[/QUOTE]
Looks like FC was running en_US.utf8 which I've now set to just the standard en_GB, and appears to have sped things up inside the VM - also not noticing any of the unicode_start processes appearing anymore which seemed to overwhelm the process list when anything accessed the system - thanks for that pointer, I didn't think of searching the forum for this as I thought it was just a problem with VMWare somewhere...
The VM was set up as a test box as you mentioned andreychek, I can't provision it on a proper server until I can show my boss that it works and works nicely, but now that the problems appear to be sorted, I'll ensure it's installed on a dedicated server :)
Thanks for all your help with this, and keep up the good work!

Return to “Users”

Who is online

Users browsing this forum: No registered users and 4 guests