Page 1 of 1

[SOLVED] After Upgrade to 6.0 mailsearch not working

Posted: Tue Sep 15, 2009 1:37 am
by mtanzer
After an upgrade to 6.0.0_GA I am not able to find Mail:



in: "inbox" from: name



or

[QUOTE]

from: @domain.com

[/QUOTE]
doesn't find anything. This was one of the best features in 5.0.x...
:-(

[SOLVED] After Upgrade to 6.0 mailsearch not working

Posted: Tue Sep 15, 2009 7:41 am
by phoenix
It works for me (and hasn't been changed) but the example you've posted is incorrect, the mailbox doesn't need quotes around it (although I'm not sure it matters). Details of the search syntax is in the wiki.

[SOLVED] After Upgrade to 6.0 mailsearch not working

Posted: Tue Sep 15, 2009 8:08 am
by mtanzer
I am using Zimbra since years and use the search function extensivly. The advanced search through the menu doesnot work as well. The quotes where made my zimbra advances search, not by me.


A somle search from: tanzer leads to:
method:	SearchRequest

msg: system failure: Caught null

code: service.FAILURE

detail: soap:Receiver

trace: btpool0-69:1253020226494:df80b0575b5c05d4

request:
Body: {

SearchRequest: {

_jsns: "urn:zimbraMail",

limit: 25,

locale: {

_content: "de"

},

offset: 0,

query: "from: tanzer",

sortBy: "dateDesc",

types: "conversation",

tz: {

id: "Europe/Berlin"

}

}

},

Header: {

context: {

_jsns: "urn:zimbra",

account: {

_content: "martin@xxxx.at",

by: "name"

},

authToken: "(removed)",

notify: {

seq: 4

},

session: {

_content: 1131,

id: 1131

},

userAgent: {

name: "ZimbraWebClient - FF3.0 (Linux)",

version: "6.0.0_GA_1802.UBUNTU6"

}

}

}


I restarted zimbra and tried again:

in:inbox from: tanzer

No errors, the GUI shows the normal mailbox.

[SOLVED] After Upgrade to 6.0 mailsearch not working

Posted: Wed Sep 16, 2009 9:59 am
by mtanzer
It seems to be a browser caching problem. I use firefox on linux - on an fresh browser ist works.