Thunderbird >24 not compatible with Zimbra

Post feedback about our hosted demo or your local install. Tell us what you love and/or what you’d like to see added in the future.
acik
Posts: 5
Joined: Wed Dec 28, 2016 4:02 pm

Thunderbird >24 not compatible with Zimbra

Postby acik » Tue Aug 29, 2017 7:29 am

I am using Zimbra at office.
Two years ago, after automatic update of Thunderbird from 24.x.x to 31.x.x I was no more able to wiew all directories and I was no more able to save in /SENT te sent mails.
Downgrade to 24.8.1 was the solution.

Now, after two years I see that the last Zimbra and the last Thunderbird they still do not talk to each other.

The last Zimbra talks correctly only with Thunderbird 24.8.1 (two years old software) !!!

Is in there any solution ??
Last edited by acik on Tue Aug 29, 2017 10:14 am, edited 1 time in total.


phoenix
Ambassador
Ambassador
Posts: 26160
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Thunderbird >24 not compatible with Zimbra

Postby phoenix » Tue Aug 29, 2017 9:03 am

I don't really understand why you think that Thunderbird version 31.x.x is the most recent release, the current version is actually 52.x.x see here: https://archive.mozilla.org/pub/thunderbird/releases/

FWIW, I've just installed the most recent release of Thunderbird (52.x.x on my openSUSE system) and it has no problem connecting to a ZCS server. You haven't really given much detail of which version of ZCS you're talking about and you should always give the output of the following command:

Code: Select all

zmcontrol -v
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
acik
Posts: 5
Joined: Wed Dec 28, 2016 4:02 pm

Re: Thunderbird >24 not compatible with Zimbra

Postby acik » Tue Aug 29, 2017 10:11 am

Zimbra don't work fine with all versions of Thunderbird for Windows newer than 24.8.1
So Thunderbird 52.x.x for Windows don't work fine with Zimbra.

I tried a lot of PC's: Windfows XP, Windows Vista, Windows 7, Windows 8, Windows 10..... I have tried a lot of vertions of Thunderbird... 31.x.x, 38.x.x 45.x.x 52.x.x .... I have the same problems !

Maybe the problem is the Windows version of Thunderbird newer then the 24.8.1 ???
phoenix
Ambassador
Ambassador
Posts: 26160
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Thunderbird >24 not compatible with Zimbra

Postby phoenix » Tue Aug 29, 2017 10:42 am

acik wrote:Zimbra don't work fine with all versions of Thunderbird for Windows newer than 24.8.1
So Thunderbird 52.x.x for Windows don't work fine with Zimbra.
That's not correct. I've just installed the latest 52.x release on a Windows 10 Pro & Enterprise plus a Windows 7 machine and all of them work fine, I'd guess the problem is likely to be on your machine. If you have any anti-virus software (or anti-malware) or perhaps a third-party firewall then I'd suggest you disable them and try again. All the tests I've done this morning indicate that Thunderbird 52.x on Linux & Windows work without problems.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
acik
Posts: 5
Joined: Wed Dec 28, 2016 4:02 pm

Re: Thunderbird >24 not compatible with Zimbra

Postby acik » Tue Aug 29, 2017 3:13 pm

Ok. I explain better.... I manage several servers and some hundreds of computers.

I tried Thunderbird/Zimbra on a lot of computers.
All versions of Windows...
A lot of different antivirus, no antivirus...

I tried different versions of Zimbra on different Linux servers.


The problem is the same ON ALL COMPUTERS that are using Thunderbird version higher than 24.8.1

Sometimes some computers works fine or they seems work fine. The user install newer Thunderbird without asking permission - but some days later, this user calls me because it cannot send new mails or cannot see old mails in subfolders.
1) when you send a mail, Thunderbird says that is not possible to save message in SENT folder
2) when you search in subfolders, a lot of subfolders are missing.
dhimler
Posts: 2
Joined: Thu Nov 24, 2016 8:44 am

Re: Thunderbird >24 not compatible with Zimbra

Postby dhimler » Tue Aug 29, 2017 5:10 pm

Hi!

You actually have not stated any error message at all yet, just vague symptoms. Could you please use the "burger button" on the upper right corner in Thunderbird to open up the activities window? It sounds to me like you are experiencing the same issues like I did, which caused Thunderbird to mark the inbox as read-only. If that's the case, you should see error messages in the activity log like "Mailbox selected READ-ONLY". It seems that the use of Ehcache (http://www.ehcache.org) is causing this. You can disable it by issuing the following command as the Zimbra user:

Code: Select all

zmlocalconfig -e imap_use_ehcache=false


You have to restart the services (at least the mailbox service) afterwards.

(Credits go to Sebastian Marsching, I found the solution on his wiki after experiencing the same problem)

Kind regards,
Daniel
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: Thunderbird >24 not compatible with Zimbra

Postby jorgedlcruz » Tue Aug 29, 2017 7:06 pm

Hi acik,
Please try the suggested method, or let us know more about the errors you are experiencing, if it's something related to the server, mailbox.log and zimbra.log will help you to debug what the problem is.

Let us know
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
acik
Posts: 5
Joined: Wed Dec 28, 2016 4:02 pm

Re: Thunderbird >24 not compatible with Zimbra

Postby acik » Mon Sep 04, 2017 1:29 pm

I will have two days of intense work and then I will do all the tests.

Thank you

Return to “Users”

Who is online

Users browsing this forum: No registered users and 3 guests