[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Ask your questions and get help with Zimbra's Outlook Connector.
15333jaustin
Posts: 6
Joined: Sat Sep 13, 2014 12:03 am

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 15333jaustin » Fri Jan 30, 2009 2:05 pm

I have a Workstation with Windows XP Pro SP2 that has had Zimbra Connector working beautifully with Outlook 2007 for several months now. A recent software update was installed yesterday to a seemingly unrelated program (Trane's HVAC selection software v. 8.6) and upon startup Outlook gave the following error:
"Cannot open your default e-mail folder. The information store could not be opened".
The offending software was removed but the damage was apparently done, as the error remained.

The profile was then deleted and Office 2007 was uninstalled. Once reinstalled and a new profile was created, Outlook just crashes before loading completely.

Outlook works fine when an IMAP or POP account is set up but crashes with the ZCS.
This is the second machine that this has happened to at our office after this software update. The first was wiped clean. I'm hoping there is a simpler solution!
Attached are core dumps and log files created.


Any help would be greatly appreciated.
Thanks!
Jill Austin

zco-cores.zip


zco-logs.zip



fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby fsiegel » Fri Jan 30, 2009 3:14 pm

I'll bet that the software update messed with your MAPI dlls.
We do have a bug out on this -- bug 33321. The description in this bug is private, but basically what is happening is that we are trying to create our internal id mapper file based on the name of the existing .zdb. Because MAPI is messed up internally, we can't get the .zdb file, and we crash at this point.
We can fix the crash and put out an error message, but you will still have the problem. What you might do is on a test machine, check the existing versions of the MAPI dlls (mapi32.dll, MSMAPI32.dl, etc.), and see if the software update changes any of those. [Maybe look for *mapi*.dll]. If these dlls are changed, maybe you can substitute ones from a good machine. If that worked, it would keep you from having to wipe these machines.
Another possibility is that the new software is changing your path variable, and maybe it now points to a bogus MAPI dll. Maybe just changing the path might help.
Worth a try, anyway.
15333jaustin
Posts: 6
Joined: Sat Sep 13, 2014 12:03 am

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 15333jaustin » Mon Feb 02, 2009 10:11 am

I checked the following dlls with a different machine that does not have this problem and all the versions are the same:

mapi32.dll

mapir.dll

MSMAPI32.dll

olmapi32.dll
I then removed Office and renamed all of the above to xxx.old.

I re-installed Office with all-new dll files but Outlook continues to crash...
By path variable, I'm afraid I'm not sure what you mean. I checked the App Path in the registry and it is pointing to C:Program FilesMicrosoft OfficeOffice12...
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby fsiegel » Mon Feb 02, 2009 10:22 am

By PATH variable, I meant the Windows Path variable. If you go to a DOS prompt and type "set", one of the variables is Path. It can be viewed and changed via Control Panel->System->Advanced->Environment Variables. If there is some other directory in the path that has different dlls, they would be picked up first, and maybe that's what is causing the problem on these machines.
Strange that the dlls seem fine. Something has messed with the Outlook installation.
15333jaustin
Posts: 6
Joined: Sat Sep 13, 2014 12:03 am

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 15333jaustin » Mon Feb 02, 2009 12:17 pm

This is the path variable: C:WINDOWSsystem32;%SystemRoot%system32;%SystemRoot%;%SystemRoot%System32Wbem;C:Program FilesCommon FilesSYSTEMMSMAPI1033
Could the software have changed something in the registry perhaps?
Thanks again!
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby fsiegel » Mon Feb 02, 2009 12:51 pm

Although repetitious (assuming %SystemRoot% is C:Windows, the ordering of the path variable looks ok. I guess you could check the difference in the path variable before and after the offending install.
Of course installing new software can mess with the registry, but I'm not sure that this problem is a reflection of that.
It still seems strange that the MAPI dlls are ok -- that would have been my first guess.
Can you say which software it is that you install that is causing the problem?
15333jaustin
Posts: 6
Joined: Sat Sep 13, 2014 12:03 am

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 15333jaustin » Mon Feb 02, 2009 1:01 pm

For what it's worth, the path variable is the same on a system without the offending software installed.
The software that I think caused this is Trane's TOPSS 8.6. It's an HVAC equipment selection software.
Could there have been other dll's affected besides the four I listed, I wonder?
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby fsiegel » Mon Feb 02, 2009 1:11 pm

So I guess it's not the path, but I know that something in the Outlook/Office installation is messed up. I went back and looked at a couple of other cases where this happened, and unfortunately, the solution seemed to be to wipe the machine.
I am trying to avoid that here, so I will keep looking to see if there is any other solution. You've obviously had to create new profiles, etc., so it's not that simple. I've looked around on the web, and I see no issues with the Trane software causing Outlook/MAPI problems.
I suppose you could compare the registry before and after, but that seems like a pain, and probably wouldn't yield anything.
I'll ask around and keep trying to find another solution. Again, even if I fix the crash, we wouldn't work correctly -- there is too much internal inconsistency.
9432henry
Zimbra Alumni
Zimbra Alumni
Posts: 126
Joined: Fri Sep 12, 2014 10:14 pm

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 9432henry » Mon Feb 02, 2009 3:09 pm

Try to remove %SYSTEM32%mspst32.dll. That is the culprit.
15333jaustin
Posts: 6
Joined: Sat Sep 13, 2014 12:03 am

[SOLVED] Outlook 2007 crash at startup with ZCS Connector ZimbraOlkConnector-5.0.1_G

Postby 15333jaustin » Mon Feb 02, 2009 3:34 pm

Removed %SYSTEM32%mspst32.dll....still crashes.
Located another MSPST32.dll in the Office 12 folder...replaced this with one from a "healthy" computer and restarted. Still crashes.

Return to “Zimbra Connector for Outlook”

Who is online

Users browsing this forum: No registered users and 4 guests