Problem moving users between two BES

Are you using the Zimbra Connector for BlackBerry? Post your comments and questions here.
eugener
Advanced member
Advanced member
Posts: 187
Joined: Fri Sep 12, 2014 11:57 pm

Problem moving users between two BES

Postby eugener » Wed Aug 19, 2009 10:12 pm

Here is a quick update on the issues rased in this thread:
1) bug 36964 mentioned by Keith has been fixed and will become available in the next closest zcb release.
2) i spent some time investigating bug 39937 and so far was able to find workaround(temporary solution) that allows to move BB users between BESs without re-provisioning device. Method below apeared to be functional although it involves usage of MFCMAPI and is inefficient for moving of big volume of users:
- installed BES1, BES2 and pointed both of them to remote SQL database. BES1 and BES2 have different SRP IDs.

- After installation both BESs became visible in BB manager under 'BlackBerry DomainServers'

- Added and enterprise activated 'User1' on BES1

- Right mouse click on 'User1' and select 'Move User' menu option

- In 'Select Server' popup choose 'BES2' and hit
- Installed MFCMAPI on both BES1 and BES2

- Stoped BB controller on BES2

- Opened up MFCMAPI

- Choose menu otption 'Session'->'Logon and Display Store Table'

- In 'Choose Profile' popup select 'BlackBerryServer' profile and hit

- In the list of message stores find and double click on the store representing 'User1' - 'Display Name' of the column will look like 'Zimbra-User1'

- In the store hierarchy please find folder 'BlackBerryHandheldInfo' that is listed under 'Root Container'. Double click on 'BlackBerryHandheldInfo'.

- In the list of the messages that showed up please select(single click on) the message with 'Message Class' column set to 'RIM.BlackBerry.Handheld.Config'

- The following are the changes that need to be made in the list of the properties corresponding to this message:

+ add the following properties

0x600C001E assign string representing server name of BES2. This server name can be found on BB manager under 'BlackBerry DomainServers'

0x6015001E assign string representing SRP ID

+ add the following properties and copy corresponding property values from corresponding configuration message located on BES1:

0x60020102

0x60030102

0x600B0003

0x601A001E

0x601B001E

0x603E0003

0x60400003

0x60560102

0x60550102

0x60710040

0x60810102
Please not that this list of properties most likely can be pruned further - do not hesitate to post elaborated list if found one.
- after above modifications are made please close MFCMAPI and start BB controller on BES2.

- verify that email service is restored
Above solution is temporary and in the future we will work to simplify this process.


kbigger
Posts: 48
Joined: Fri Sep 12, 2014 10:34 pm

Problem moving users between two BES

Postby kbigger » Thu Aug 20, 2009 7:02 am

very nice, eugene. It seems straight forward although, as you say, cumbersome for large numbers of users. I think that the implementation of this in the next ZCB rev will encourage admins to ramp up the user count on their BES's. The inability to move large groups is what keeps me from doing it.
One question, which step in the process moves the .zdb file from bes1 to bes2?
eugener
Advanced member
Advanced member
Posts: 187
Joined: Fri Sep 12, 2014 11:57 pm

Problem moving users between two BES

Postby eugener » Thu Aug 20, 2009 1:18 pm

>One question, which step in the process moves the .zdb file from bes1 to bes2?
.zdb file will be created automatically by BES2 right after 'Move User' step above is executed. No action on user side is needed.
Again, i will try to simplify this process in the future. In addition, large groups can also be potentially moved using method above, however it will take some extra effort.
kubanoba
Posts: 7
Joined: Sat Sep 13, 2014 12:35 am

Problem moving users between two BES

Postby kubanoba » Thu Jan 07, 2010 5:50 pm

Eugener, thaks a lot!!!!! I've see that you fix bug 39937, you and zimbra support team really rocks!!!
My Zimbra mailserver admin upgraded our ZCS version to 6.0.4 (I think) and both bes servers are using ZCB 5.0.19. My question is: I need to wait to new ZCB version release or zimbra support will send me a fix?
Which will be the future steps to close this bug?
Millions of thank again.


Regards
eugener
Advanced member
Advanced member
Posts: 187
Joined: Fri Sep 12, 2014 11:57 pm

Problem moving users between two BES

Postby eugener » Thu Jan 07, 2010 6:40 pm

I suspect that we will promptly do maintenance release based on 5.0.x line of code after QA will be done with verification. Thanks for your patience.
jim.ling71
Posts: 1
Joined: Sat Sep 13, 2014 1:46 am

Problem moving users between two BES

Postby jim.ling71 » Mon Jan 10, 2011 1:57 pm

Hmmmm. I trying steps and it not working for me. Still on old version of server and connector so trying manual steps. BES logs say "detected incomplete move" but the device is dead even after waiting for hours. Should I try copy all BlackBerryHandheldInfo properties instead of just a subset?

Also I get error about invalid number of messages. Do I need to create other message too? I think that it BlackBerry.stats message.
eugener
Advanced member
Advanced member
Posts: 187
Joined: Fri Sep 12, 2014 11:57 pm

Problem moving users between two BES

Postby eugener » Tue Jan 11, 2011 12:54 pm

Starting from zcb 5.0.24, the process of moving users between BES instances became automatic so that copying of mapi rpoperties is no longer necessary. I would recommend to upgrade to the newer version of connector or otherwise please contact support@zimbra.com in case if you need assistance with old version.

Return to “Zimbra Connector for Blackberry”

Who is online

Users browsing this forum: No registered users and 1 guest