[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Are you using the Zimbra Connector for BlackBerry? Post your comments and questions here.
245centrex
Advanced member
Advanced member
Posts: 96
Joined: Fri Sep 12, 2014 10:42 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby 245centrex » Sat May 24, 2008 6:14 am

Hi,
Is it intended that BES can only "see" accounts that are in the same domain as the BlackBerryManager user ?
I have 1 BES server in trial, talking to one ZCS NE server which hosts many domains.
It seems I can only activate / provision / see accounts from the same domain that the manager account was created in, thus I am not able to let users from other domains connect via BES ?


gmsmith
Outstanding Member
Outstanding Member
Posts: 432
Joined: Fri Sep 12, 2014 10:09 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby gmsmith » Sat May 24, 2008 8:29 pm

Yes, this is a known issue. You can use multiple BES servers against a single Zimbra instance to get around this. You can also disable GAL lookups on the device and make it work that way, though I am not sure if Zimbra will support that if you do. So use the following at your own risk:
To disable the Global Address Book Lookup feature, complete the following

steps on the BES server:


1. On the BlackBerry Enterprise Server, go to Administrative Tools, double-click Services, and stop the BlackBerry Enterprise Server Service.

2. Open the Registry Editor by clicking Start > Run. Type regedit, then click OK.

3. For BlackBerry Enterprise Server 3.5 and 3.6, go to HKEY_LOCAL_MACHINESoftwareResearch In MotionBlackBerry Enterprise ServerServers
For BlackBerry Enterprise Server 4.0 and 4.1, go to

HKEY_LOCAL_MACHINESoftwareResearch In MotionBlackBerry Enterprise Server

4. Depending on your BlackBerry Enterprise Server version, right-click either the registry key or the Agents registry key, then click New > DWORD Value.

5. Type AllowAddressLookup as the name of the new DWORD Value, then press ENTER.

6. Double-click AllowAddressLookup.

7. In the Value data field, type 0, then click OK.

8. Close the Registry Editor, then restart the BlackBerry Enterprise Server.

Then the BES admin has to be in its own domain where the entire GAL is available.
On the Zimbra Server:
1. Create a domain with search base set to ROOT for search and sync

zmprov cd gal.example.com zimbraGalInternalSearchBase ROOT zimbraGalSyncInternalSearchBase ROOT

2. Create an admin account in the domain:

zmprov ca admin-1@gal.example.com test123 zimbraIsAdminAccount TRUE



3. Auth to Zimbra as admin-1@gal.example.com and GAL search/sync will return entries in all domains.
Again, I do not know if Zimbra will support you with this, so please use at your own risk. And remember the Blackberry connector is in beta at this point. They may address this in the final release, so you may just want to wait until that happens. And to answer the next question, it will be out when it is ready. :)
245centrex
Advanced member
Advanced member
Posts: 96
Joined: Fri Sep 12, 2014 10:42 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby 245centrex » Sat May 24, 2008 10:08 pm

Thanks for your reply. :)
I will mark this as solved, seeing as it seems to be a known issue. It's not a show stopper for me, just something I needed to confirm so I can plan my implementation accordingly.
So far it's been smooth sailing for me.
Upgraded from 5.0.5 Community Edition to 5.0.5 ZCS NE, backed up, moved it off the VM it lived on for the last two years and onto it's own SUN x4100, upgraded to 5.0.6 and installed a Win3k server with Blackberry Professional (the 10 seat thing for SME users) in a VM and successfully activated a device.
All this in less than two working days, none of which would have been possible without people like yourself who participate in this forum and the Zimbra Wiki.
My BES implementation is still a bit unpolished. As a BES newbie there's still lots to learn with regards to security policies and all the crazy stuff you can do over the air but all the Zimbra bits and pieces "just worked".
:)
mlanner
Advanced member
Advanced member
Posts: 111
Joined: Fri Sep 12, 2014 11:13 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby mlanner » Mon Oct 13, 2008 12:43 pm

I'm trying to get our BlackBerry server (actually a BPS, not BES ... yet) to interact with multiple domains on one Zimbra NE server.
Have you been running your BES in "production" in the manner that you describe in your post? And if so, have you had any problems with it?
I read in another thread (http://www.zimbra.com/forums/zimbra-connector-blackberry/21011-zcb-beta-3-released.html) that there are new features in ZBC Beta 3 (early August) that may or may not make this possible.
Any input you have would be greatly appreciated.
Thanks.
catnipper
Advanced member
Advanced member
Posts: 71
Joined: Fri Sep 12, 2014 11:45 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby catnipper » Mon Dec 01, 2008 4:16 am

Hi,

I was running into problems adding a new domain AFTER deploying the ZBC connector successfully. Suddenly, I was not able anymore to activate users (as I was testing on a 1 user BlackBerry server I can not tell if this also applies for existing users).

The solution was found by chance: seems like the change of adding a new domain did not work well for the GAL in ZBC - I had a list of users from both domains, although they existed only on one: abc@example.com & abc@example.de
Reinstalling the ZBC and recreating the BlackBerryManager and BlackBerryServer mail profiles helped immediately!
Hope this may help anybody else running into similar problems.
bangsters
Advanced member
Advanced member
Posts: 149
Joined: Fri Sep 12, 2014 10:39 pm

[SOLVED] ZBC - 1 ZCS NE server with multiple domains - Only 1 domain appears in G

Postby bangsters » Fri Aug 07, 2009 8:29 pm

I tried this same instructions but have differnet results.
If I log into webmail as the BB admin, I can see all domains in GAL. However, if I log into Outlook 2007 or in BES Manager (actually BPS Manager), no contact shows up in GAL.
Any way I can get it to show up??? It's showing up in webmail so I know it's set as ROOT.

Return to “Zimbra Connector for Blackberry”

Who is online

Users browsing this forum: No registered users and 1 guest