Stuck on installation of ZCB Beta3

Are you using the Zimbra Connector for BlackBerry? Post your comments and questions here.
stich86
Advanced member
Advanced member
Posts: 123
Joined: Fri Sep 12, 2014 11:10 pm

Stuck on installation of ZCB Beta3

Postby stich86 » Fri Aug 08, 2008 3:15 am

Hi guys,
yesterday, when i say the release of lastest ZCB connector, i've installed in a new bes server with outlook 2007 (with the last events, we've decided to start from scratch on september, because the BES migration doesn't work..)
but when i try to create the BES profile on the Mail icon in Control Pannel, after selecting ZCB as server connector, the application hangs :(
anyone can tell me how to solve this problem?


10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Fri Aug 08, 2008 10:59 am

[quote user="stich86"]Hi guys,
yesterday, when i say the release of lastest ZCB connector, i've installed in a new bes server with outlook 2007 (with the last events, we've decided to start from scratch on september, because the BES migration doesn't work..)
but when i try to create the BES profile on the Mail icon in Control Pannel, after selecting ZCB as server connector, the application hangs :(
anyone can tell me how to solve this problem?[/QUOTE]
i saw this once during development and it turned out that it was DLL and path issues. can you search that machine for all instances of mapi32.dll, mapi32.dll.zco, mspst32.dll and mspst32.dll.zco and tell me where each file is located, the size of the file and the version of the file. its possible that one of these DLLs is not the correct one.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Mon Aug 11, 2008 12:11 pm

[quote user="stich86"]Hi guys,
yesterday, when i say the release of lastest ZCB connector, i've installed in a new bes server with outlook 2007 (with the last events, we've decided to start from scratch on september, because the BES migration doesn't work..)
but when i try to create the BES profile on the Mail icon in Control Pannel, after selecting ZCB as server connector, the application hangs :(
anyone can tell me how to solve this problem?[/QUOTE]
any updated status on this one? have you gotten things working?
DanCody
Posts: 34
Joined: Fri Sep 12, 2014 9:57 pm

Stuck on installation of ZCB Beta3

Postby DanCody » Thu Aug 14, 2008 10:18 am

This is also happening for us on installation of ZCB 3 - once we choose Zimbra Collaboration Server as the server type, the mail applet hangs and CPU hits 100%.
I couldn't find mapi32.dll.zco on our server. Our mapi32.ddl is 622KB
Dan
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Thu Aug 14, 2008 11:06 am

[quote user="DanCody"]This is also happening for us on installation of ZCB 3 - once we choose Zimbra Collaboration Server as the server type, the mail applet hangs and CPU hits 100%.
I couldn't find mapi32.dll.zco on our server. Our mapi32.ddl is 622KB
Dan[/QUOTE]
can you look for the following files and send me the size, location and version number (if applicable)
mspst32.dll

mspst32.dll.zco (might not exist)

mapi32.dll

mapi32.dll.zco (might not exist)

emsmdb32.dll

emsmdb32.dll.zco (might not exist)

mapisvc.inf

cdo.dll

msmapi32.dll

olmapi32.dll
please provide all the info so we can try to to debug what is going on.

did you perform an upgrade from 2003 to 2007 or was this a fresh install?
DanCody
Posts: 34
Joined: Fri Sep 12, 2014 9:57 pm

Stuck on installation of ZCB Beta3

Postby DanCody » Thu Aug 14, 2008 11:33 am

mspst32.dll.zco windowssystem32 480KB version 6.5.7974.0

MSPST32.DLL program filesmicrosoft officeoffice12 1,047KB version 12.0.4518.1014
mapi32.dll windowssystem32 622KB version 6.5.7974.0

mapi32.dll.zco doesn't exist
emsmdb32.dll program filesmicrosoft officeoffice12 520KB version 5.0.2672.9

EMSMDB32.DLL windowssystem32 1,296KB version 6.5.7974.0

emsmdb32.dll.zco program filesmicrosoft officeoffice12 1,455KB versin 12.0.4518.1014
Mapisvc.inf program filescommon filessystemmsmapi1033 4KB

MAPISVC.INF windowssystem32 2KB
CDO.DLL windowssystem32 755KB version 6.5.7974.0
Outlook 2007 was a fresh install.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Thu Aug 14, 2008 11:35 am

[quote user="DanCody"]mspst32.dll.zco windowssystem32 480KB version 6.5.7974.0

MSPST32.DLL program filesmicrosoft officeoffice12 1,047KB version 12.0.4518.1014
mapi32.dll windowssystem32 622KB version 6.5.7974.0

mapi32.dll.zco doesn't exist
emsmdb32.dll program filesmicrosoft officeoffice12 520KB version 5.0.2672.9

EMSMDB32.DLL windowssystem32 1,296KB version 6.5.7974.0

emsmdb32.dll.zco program filesmicrosoft officeoffice12 1,455KB versin 12.0.4518.1014
Mapisvc.inf program filescommon filessystemmsmapi1033 4KB

MAPISVC.INF windowssystem32 2KB
CDO.DLL windowssystem32 755KB version 6.5.7974.0
Outlook 2007 was a fresh install.[/QUOTE]
wow you are quick. i actually editted my post and added olmapi32.dll and msmapi32.dll to the list.
at first glance it looks like there are a couple of DLLs where they should not be. do you have files located at program filesexchangemapi?
DanCody
Posts: 34
Joined: Fri Sep 12, 2014 9:57 pm

Stuck on installation of ZCB Beta3

Postby DanCody » Thu Aug 14, 2008 1:54 pm

OLMAPI32.DLL program filesmicrosoft officeoffice12 2.80MB version 12.0.4518.1014

MSMAPI32.DLL program filescommon filessystemmsmapi 49KB 12.0.4518.1014
We don't have a folder named exchangemapi in program files at all.
As for the location of the DLLs, this is a clean install of Office 2007 and the ZCB3 so I don't know how they'd be in the wrong place.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Thu Aug 14, 2008 2:02 pm

[quote user="DanCody"]OLMAPI32.DLL program filesmicrosoft officeoffice12 2.80MB version 12.0.4518.1014

MSMAPI32.DLL program filescommon filessystemmsmapi 49KB 12.0.4518.1014
We don't have a folder named exchangemapi in program files at all.
As for the location of the DLLs, this is a clean install of Office 2007 and the ZCB3 so I don't know how they'd be in the wrong place.[/QUOTE]
try renaming mspst32.dll in windowssystem32 to something like mspst32.dll.zco and then try renaming the emsmdb32.dll in windowssystem32 to something like emsmdb32.dll.zco and see if it works.

this could be problem with the old mapicdo installer and the zcb installer.

the only other thing that worries me is that the mapi32.dll in windowssystem32 might not be the right one. but try the renames and give it a try.
--tony
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Thu Aug 14, 2008 2:17 pm

[quote user="DanCody"]There is no mspst32.dll in windowssystem32 - mspst32.dll.zco is there already.[/QUOTE]
ok..then just rename the emsmdb32.dll to a .zco extension and try it again.

it also looks like the mapi32.dll in windowssystem32 is wrong but i don't know why outlook 2007 did write over it. but give it a try anyway.

Return to “Zimbra Connector for Blackberry”

Who is online

Users browsing this forum: No registered users and 1 guest