iOS4 + CardDAV - return characters in notes?

Questions, comments, and problems with Zimbra on Apple desktops & general CalDAV / CardDAV questions.
1319arion
Posts: 4
Joined: Fri Sep 12, 2014 10:06 pm

iOS4 + CardDAV - return characters in notes?

Postby 1319arion » Fri Aug 13, 2010 9:25 am

Hi everyone,
I've got Zimbra 6.0.7 running and have CardDAV configured on both my Mac (Address Book) and my iPhone 4. It works great! Kudos to the Zimbra development team. However, I've noticed one slight issue when viewing address book entries on the iPhone.
When I view any notes that I have assigned to a contact (the vCard "NOTE" field), any place where I have a return character, I see the upper case character "N" on the iPhone instead. The notes don't include any line breaks on the iPhone. I'm guessing this is an iOS bug, but perhaps there could be a Zimbra work-around? When viewing the same contact in the Apple Address Book, it looks fine. And if I export the contact from Address Book, the vCard file shows "
" (the newline character) as I would expect. The notes also render fine when viewed in the Zimbra web interface.
Anyone else seeing this same issue?
Thanks,

Arion


dbhbln
Posts: 1
Joined: Sat Sep 13, 2014 1:24 am

iOS4 + CardDAV - return characters in notes?

Postby dbhbln » Mon Aug 16, 2010 8:02 am

Hi there,
that is the first evidence i can find in the web, that this should work.

we still cant figure out how to get this to work. perhaps someone can help or can give a hint.
we use a zimbra provider who roled out 6.0.7

we use iphones with ios 4.0.2
perhaps some can give a hint on filling the right user credentials in the setting tabs on the iphone
we tried:
(german mask)

Server: zimbra.ourprovider.de

Benutzer: info@ourmaildomain.de

Kennwort: geheim

Beschreibung: egal
is there perhaps a problem, that we use different domain for the server and our username?
sincerly dbhbln
tachijuan
Advanced member
Advanced member
Posts: 59
Joined: Fri Sep 12, 2014 9:56 pm

iOS4 + CardDAV - return characters in notes?

Postby tachijuan » Wed Aug 18, 2010 3:52 pm

This is also the first time that I see that this is working for someone.
I'm running OE 6.0.7 for Zimbra. My desktop is Snow Leopard 10.6.4. I also have iOS 4.0.1 on my phone. Neither one of them can connect. On both I use the following:
Account Type: CardDAV

User Name: myemail@mydomain.com

Password : ********

Server Address: mail.mydomain.com
mail.mydomain.com is the cname of my mail server. I've also tried using the a record DNS entry and neither works. Any help would be greatly appreciated.


TIA
ps IMAP and calDAV work beautifully. Just one more step....
Tripple
Outstanding Member
Outstanding Member
Posts: 285
Joined: Sat Sep 13, 2014 12:22 am

iOS4 + CardDAV - return characters in notes?

Postby Tripple » Thu Aug 19, 2010 2:26 pm

Finally I was able to use CardDAV on my iPhone. Buggy, but once the account is setup it works in both directions.
Zimbra 6.0.7_GA_2473.RHEL5_20100616214455 CentOS5 FOSS edition

iPhone iOS 4.0.2
- Create a new CardDAV account

- Server: zimbraserver.yourdomain.com

- Username: account@yourdomain.com

- Ignore all errors, disable the account with the slider

- Save your settings

- Advanced: Port 80 or SSL 443

- Save your settings

- Make sure all settings are still there after you left the setup page

- Make the account active, ignore the errors
Check your contacts, there's your Zimbra server.

Return to “CalDAV / CardDAV / iSync”

Who is online

Users browsing this forum: No registered users and 1 guest