Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

General discussion about Zimbra Desktop.
Ahmad Faizal Abdul Latif
Posts: 17
Joined: Sun Feb 02, 2014 9:10 pm

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby Ahmad Faizal Abdul Latif » Sun Feb 08, 2015 6:58 am

I just upgrade our server to latest 8.6 Network Edition. Now we are facing issue where client will not able to login to webmail using http with error "Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.". but they will not have any issue when they login using https. due to our server is hosting few domains for different users, we cannot ask them to use https as they will get ssl error. i have check the cookie is enabled inside the browser, this only happened after i upgrade the server to 8.6.


from nginx log i can see:


2015/02/08 20:49:01 [info] 15838#0: *181 client prematurely closed connection while reading client request line, client: 113.210.10.79:56520, server: mail.myserver.com.default



Does anyone have any issue like this?



User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby jorgedlcruz » Sun Feb 08, 2015 11:41 am

Hi Ahmad Faizal Abdul Latif,


I've tried with zmtlsctl in both, I can assume that you have it too in the same level, try to execute:


zmtlsctl redirect
zmcontrol restart
zmtlsctl both
zmcontrol restart

And let us know, I could see the error that you had one, but when I try to login again, I don't have any problem now.


Let us know.

Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
Ahmad Faizal Abdul Latif
Posts: 17
Joined: Sun Feb 02, 2014 9:10 pm

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby Ahmad Faizal Abdul Latif » Sun Feb 08, 2015 8:12 pm

Hi Jorge de la Cruz,



i try the solution you give last night but no luck for me. i force proxy regenerate config again last night. using the step at this link http://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy



using the command zmproxyconfig. and restart zimbra then it works fine. i believe the issue is with the nginx configuration not able to set/check cookies to the client browser.



but the issue resolve now.
tvizirov
Zimbra Employee
Zimbra Employee
Posts: 21
Joined: Fri Jan 23, 2015 10:32 am

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby tvizirov » Thu Apr 30, 2015 10:59 am

Here is one solution which was tested and worked:

Steps:
(In this example, we have http and https enabled)

1. Reconfigure nginx:
$ /opt/zimbra/libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x both -H `zmhostname`

2. If the ''zimbraReverseProxySSLToUpstreamEnabled'' is configured to TRUE, the above command will fail with:
"proxy mail mode both is invalid when SSL to upstream is enabled". To change it to FALSE
$ zmlocalconfig zimbraReverseProxySSLToUpstreamEnabled FALSE

3. $ zmtlsctl both

4. $ zmprov ms `zmhostname` zimbraReverseProxyMailMode both

5. $ zmprov ms `zmhostname` zimbraMailMode both

6. $ zmcontrol restart


The commands above need to be run on all proxy servers.  


Steps 1-2 might be skipped, but it was not tested if skipping them will fix the problem %100. 

cehau37
Posts: 4
Joined: Sat Sep 13, 2014 3:52 am

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby cehau37 » Mon Sep 21, 2015 12:24 am

Hi Ahmad,



I'm running into the same problem as you. Just want to confirm that you were doing the steps below to fix it.



If localconfig key 'zimbra_require_interprocess_security' is set, Only "https" and "both" are valid modes

./libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x <https/both> -H `zmhostname`

Else if 'zimbra_require_interprocess_security' is unset, Only "http" and "both" are valid modes

./libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x <http/both> -H `zmhostname`

Set the mail proxy ports

./libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H `zmhostname`

Now, to have all the mailbox servers use the proxy, simply set the zimbraMailReferMode to reverse-proxied on each mailbox server and restart mailboxd to have all the traffic go through the proxy. Do a 'zmcontrol restart' on this node and you should be up and running.



Please advise.
Ahmad Faizal Abdul Latif
Posts: 17
Joined: Sun Feb 02, 2014 9:10 pm

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby Ahmad Faizal Abdul Latif » Mon Sep 21, 2015 8:29 am

Hi cehau37,



yes. i just follow the step in the document and it is running fine after that. just make sure the ports are correct. i believe tvizirov step also correct. you can follow it.



thanks.
ADota
Posts: 11
Joined: Mon Jun 22, 2015 6:45 pm

Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Client.

Postby ADota » Sat Jan 02, 2016 10:16 pm

thanks you sir, its really worked :)
Blueberry
Posts: 5
Joined: Thu Jan 25, 2018 12:14 pm

Re: Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Clie

Postby Blueberry » Thu Mar 22, 2018 9:59 am

tvizirov wrote:2. If the ''zimbraReverseProxySSLToUpstreamEnabled'' is configured to TRUE, the above command will fail with:
"proxy mail mode both is invalid when SSL to upstream is enabled". To change it to FALSE
$ zmlocalconfig zimbraReverseProxySSLToUpstreamEnabled FALSE

Better use:

zmprov ms `zmhostname` zimbraReverseProxySSLToUpstreamEnabled FALSE
Jerry
Posts: 2
Joined: Thu May 17, 2018 10:55 am

Re: Oops! It appears your browser does not allow cookies. You need to enable cookies in order to use the Zimbra Web Clie

Postby Jerry » Thu May 17, 2018 11:16 am

jorgedlcruz wrote:Hi Ahmad Faizal Abdul Latif,
I've tried with zmtlsctl in both, I can assume that you have it too in the same level, try to execute:
zmtlsctl redirect
zmcontrol restart
zmtlsctl both
zmcontrol restart
And let us know, I could see the error that you had one, but when I try to login again, I don't have any problem now.
Let us know.


It worked for me.

Thanks Jorgedlcruz

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 6 guests