ZD Install in AppData/Local, Loses Setup on Log Out

General discussion about Zimbra Desktop.
kbigger
Posts: 48
Joined: Fri Sep 12, 2014 10:34 pm

ZD Install in AppData/Local, Loses Setup on Log Out

Postby kbigger » Thu Nov 10, 2011 11:55 am

I'm on Win 7 in an enterprise net w/roaming profiles. I installed ZD to do zimlet stuff and found that, since ZD init puts files in /User//AppData/Local, ZD forgets account setups across sessions because our GPO clears AppData/Local when the user logs off.
It appears as though I could mod one or all of the following to fix this
a) DataRoot and OverridePath reg keys

b) override.ini beneath AppData,

c) override.ini below Programs

d) zdrun.vbs
It looks like kluding up the vbs variable sLocalAppDir might be the minimalist fix but I'm not a vbs guru. This issue looks like it's related to bug https://bugzilla.zimbra.com/show_bug.cgi?id=52003 but not exactly.
Is there a clean way to do this? TIA.


17416jflanigan
Zimbra Alumni
Zimbra Alumni
Posts: 113
Joined: Sat Sep 13, 2014 1:20 am

ZD Install in AppData/Local, Loses Setup on Log Out

Postby 17416jflanigan » Thu Nov 10, 2011 5:05 pm

Modifying zdrun.vbs is your best bet. I'm assuming you are running ZD 7.1.2, so you can change the &H1c& to another folder constant. For example &H1a& is the 'Application Data ' folder.
sLocalAppDir = oFso.getFolder(oShellApp.Namespace(&H1a&).Self.Path).ShortPath
You might also be able to use &H28& (user profile). The full list of folder constants is described here: Microsoft Windows 2000 Scripting Guide - Enumerating Special Folders
Once you have made the change, you will also want to remove the DataRoot and OverridePath reg keys so ZD uses the new path.
kbigger
Posts: 48
Joined: Fri Sep 12, 2014 10:34 pm

ZD Install in AppData/Local, Loses Setup on Log Out

Postby kbigger » Fri Nov 11, 2011 7:49 am

thanks jflaningan. figured there was a one-line solution. i googled that variable but came up empty. guess i wasn't persistent enough.
SmithMartinChristopher
Posts: 10
Joined: Sat Sep 13, 2014 2:19 am

ZD Install in AppData/Local, Loses Setup on Log Out

Postby SmithMartinChristopher » Fri Nov 11, 2011 2:18 pm

I am having a similar issue with a Windows 7 64Bit client and 7.1.2 of the desktop. Every couple of days, I have had to either rebuild the user settings because they "disappeared" or even reinstall the app (only 1 time though).
I will report back.

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 3 guests