Linux and Windows fails to start

General discussion about Zimbra Desktop.
kevindods
Advanced member
Advanced member
Posts: 164
Joined: Fri Sep 12, 2014 9:58 pm

Linux and Windows fails to start

Postby kevindods » Wed Mar 28, 2007 11:49 am

Hi All,
I have been looking forward to this extra bit of functionality to the Zimbra line up. I had a couple of hours today to play and just off the top on the first attempt, the desktop software installs on Windows and Ubuntu 6.10 (well nearly- hangs when starting service) but no connection can be made to the localhost/port using the required URL. This is, I strongly suspect, because the zdesktop service reports status as not running and fails to start ;-)
Other than the need for certain software ie Java from the install are there any 'not-requirements' such as dont have another webserver installed or any other Java install etc.
Not much in the logs for install, just in the terminal I see:
log4j:WARN No appenders could be found for logger (org.apache.commons.httpclient.HttpClient).

log4j:WARN Please initialize the log4j system properly.

Error: invoke Connection refused, server: localhost
To save a bit of time on my part, any hints would be welcome!
Kevin


dkarp
Elite member
Elite member
Posts: 1410
Joined: Fri Sep 12, 2014 9:52 pm

Linux and Windows fails to start

Postby dkarp » Wed Mar 28, 2007 12:26 pm

When you installed the software, what URL did you give for your remote Zimbra server?
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Linux and Windows fails to start

Postby jjzhuang » Wed Mar 28, 2007 3:37 pm

Do you get the same failure on both Windows and Ubuntu?
kevindods
Advanced member
Advanced member
Posts: 164
Joined: Fri Sep 12, 2014 9:58 pm

Linux and Windows fails to start

Postby kevindods » Wed Mar 28, 2007 4:00 pm

I didn't get as far as setting up the server name etc., it failed after attempting to start the daemon/service before any configuration dialogue. Is that part of the basic install? In which case it could be said not to have installed properly I guess.
Yes both windows XP and linux versions had similar issues although the toaster configured and worked fine on the XP talking to the Zimbra server, so it would feel like Java itself is working for it.
Thanks,
K
kevindods
Advanced member
Advanced member
Posts: 164
Joined: Fri Sep 12, 2014 9:58 pm

Linux and Windows fails to start

Postby kevindods » Wed Mar 28, 2007 4:15 pm

when uninstalling on Linux (ubuntu6.10) I get and error:
java.io.FileNotFoundException: /home/user/zimbra/zdesktop/.install4j/files.log
Error log: /tmp/install4jError12092.log
Not much in the log that looks useful, can post if helpful. Bombs out and doesnt complete uninstall.
K
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Linux and Windows fails to start

Postby jjzhuang » Wed Mar 28, 2007 4:50 pm

Currently we have an issue that if the installation itself failed, uninstalling doesn't work. Please refer to README.txt about how to maunally remove zdesktop.
I'm a little surprised to hear you run into the same issue on two independent boxes. I'd like to know if you get any further on second try.
nwatson
Posts: 10
Joined: Fri Sep 12, 2014 10:27 pm

Linux and Windows fails to start

Postby nwatson » Sun Apr 01, 2007 11:47 pm

I'm having the same problem. Same error about log4j under both Ubuntu 7.04 and Windows XP.
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Linux and Windows fails to start

Postby jjzhuang » Mon Apr 02, 2007 2:01 am

The log4j warnings can be ignored. Do you have any real problems?
kevindods
Advanced member
Advanced member
Posts: 164
Joined: Fri Sep 12, 2014 9:58 pm

Linux and Windows fails to start

Postby kevindods » Mon Apr 02, 2007 6:00 am

Concentrating on the Edgy box I removed the directory and cleaned up what I could see. Downloaded a fresh file just in case something was corrupted ;-) Installed and it got to the same place same error.
Just speculating for reasons and wondered what permissions does this need to install? After giving the script execute permissions it appears to run happily in userspace. Ubuntu uses sudo as a default but there appears no requirement for higher than user permissions on the install.
I have been reading everything carefully so I dont miss anything, and so as a side point it looks like this may become a Network only extra. Carefully reading the Desktop page with the line stating pricing has not been determined. Any further comment on that? I presume even with the Zimbra variant of GPL license you cant retract code released but could it be that this will not be community supported by Zimbra and a Network version would be?
Anyhow, at the moment Desktop isnt installing for me, any further thoughts on the areas to look at?
Cheers
Kevin
nwatson
Posts: 10
Joined: Fri Sep 12, 2014 10:27 pm

Linux and Windows fails to start

Postby nwatson » Mon Apr 02, 2007 7:33 am

[quote user="jjzhuang"]The log4j warnings can be ignored. Do you have any real problems?[/QUOTE]
Yes... it hangs there, and won't start.

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 4 guests