Linux and Windows fails to start

General discussion about Zimbra Desktop.
jjzhuang
Elite member
Elite member
Posts: 1687
Joined: Fri Sep 12, 2014 10:24 pm

Linux and Windows fails to start

Postby jjzhuang » Mon Apr 02, 2007 11:50 am

If the java process exists but just somehow hanging, please do a "kill -3 " and file a bug with the stack trace dump in zdesktop.out.
Also whenever open a bug please attach the mailbox.log file. Thanks!


azeem
Posts: 29
Joined: Fri Sep 12, 2014 10:35 pm

Linux and Windows fails to start

Postby azeem » Tue May 29, 2007 9:54 am

I think I solved this install problem now.
Details. Server running Ubuntu 06.04 LTS, client running Ubuntu 07.04.
I had the exact same problem described above, where the install process did not complete, and the zdesktop procces terminating after a few secs.
I manually cleaned my previous installation according to the README.txt

I've also had som problems with blank setup windows due to an incomatibility with Beryl, and this command line was supposed to solve that: AWT_TOOLSKIT=MToolkit sh zdesktop_unix_0_38.sh
It dind't, so I stopped Beryl, before installation. Previously I have installed Desktop as root (using sudo) and used the default installation location: /root/zimbra. According to another post, a Zimbra employee said that the installation could well be done in user space and in the home directory.
So from my home directory, i type: AWT_TOOLSKIT=MToolkit sh zdesktop_unix_0_38.sh

I specify install directory: /home//zimbra. After the initial dialogs, I get write errors to the directories. It turns out that desktop setup copies all files and folders with root as owner. With 'chown' I make myself owner of all files and directories under the ./zimbra directory, and there it is. The installation completes, and the right jobs are started.

Just make sure you don't forget the .install4j directory!
When the installation is complete, the client is started, an the account connection params can be specified; server URL, username and password. The server URL I specified as http://servername.domain.tld - no port number and no folder!!
So now I have zDesktop up and running on linux.
Btw. the windows version worked for me all the time. Just make sure you don't change to Theme=steel when running Zimbra Desktop. Although this works with the web client, it does NOT work with zDesktop. And there is no way back either. I have searched all of registry, and all the config files I can find on Zimbra to reset the theme to something other than steel, but no such luck. zDesktop will NOT start again, and all I get is a message that Steel is not supported.

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 4 guests