CSFE_SVC_ERROR intermittently since upgrade to 8.5

General discussion about Zimbra Desktop.
abatie
Advanced member
Advanced member
Posts: 61
Joined: Thu Aug 07, 2014 12:02 pm

CSFE_SVC_ERROR intermittently since upgrade to 8.5

Postby abatie » Fri Oct 24, 2014 3:27 pm

This seems to be related to the bug in ldap queries timing out in Zimbra 7 that I'd heard was fixed in Zimbra 8.something.  We upgraded to 8.5 a couple days ago.  In the admin interface today, I got:


Error code: CSFE_SVC_ERROR Method: SearchDirectoryRequest Details:HTTP response status 503


when doing an account lookup.  And a user reported this error occurring after using the zimbra web interface for "a while":


A network service error has occurred.
method: MsgActionRequest
msg:    A network service error has occurred.
code:   CSFE_SVC_ERROR
detail: HTTP response status 502


Any pointers would be appreciated, thanks!



User avatar
btriem
Posts: 3
Joined: Tue Mar 11, 2014 6:45 pm

CSFE_SVC_ERROR intermittently since upgrade to 8.5

Postby btriem » Wed Nov 05, 2014 4:54 pm

You may want to take a look at the following:


DoSFilter


Take a look at your zmmailboxd.out file and grep for DoSFilter.  If you get anything like the below:



2014-11-05 10:08:09.598:WARN:oejs.DoSFilter:DOS ALERT: ip=some.internal.ip.address,session=kgemr7r33rj07mlcgfrpia6w,user=null


Then your DoSFilter is being hit.  Follow the documentation and you can add your local IP's to the whitelist and tweak other settings to help reduce false positives on the DoSFilter.  It helped us in a very similar situation.


EDIT:


If you still see the CSFE error and you use the nginx proxy and you see the following in /opt/zimbra/zmmailboxd.out


2014/11/05 07:48:12 [error] 23712#0: *159734 no live upstreams while connecting to upstream, client: client.ip.address, server: server.dns.name, request: "POST /service/soap/SearchRequest HTTP/1.1", host: "email.alliance.com", referrer: "https://server.dns.name/zimbra/"


then please take a look at Bug 80135


# This will configure proxy to immediately reconnect on any failure

$ zmprov mcf zimbraMailProxyReconnectTimeout 0
$ zmprov ms `zmhostname` zimbraMailProxyReconnectTimeout 0

# this will configure proxy to ignore failures as regards to disconnects

$ zmprov mcf zimbraMailProxyMaxFails 0
$ zmprov ms `zmhostname` zimbraMailProxyMaxFails 0

Then, restart the processes on all proxies:
$ zmproxyctl restart


Brad

Regards,
Brad
abatie
Advanced member
Advanced member
Posts: 61
Joined: Thu Aug 07, 2014 12:02 pm

CSFE_SVC_ERROR intermittently since upgrade to 8.5

Postby abatie » Wed Nov 05, 2014 6:06 pm

We do see a few of those and working on the suggested fix, thanks!

Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 4 guests