Page 1 of 1

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Wed Jan 28, 2015 4:25 pm
by Lukasz Michalik

Hello,


I've upgraded from ZCS 8.0 to 8.6 and now have problems with zimbraMtaSmtpdMilters parameter. It's not "transferred" to MTA main.cf configuration file.


I'm installing milter using:


zmprov ms `hostname` zimbraMtaSmtpdMilters inet:localhost:7777


and later invoking


zmprov gs `hostname` zimbraMtaSmtpdMilters


gives me good results:


zimbraMtaSmtpdMilters: inet:localhost:7777


But main.cf configuration file has empty smtpd_milters property (it didn't update) and communication between MTA and milter is not working. When I manually change smtpd_milters everything is working like a charm, but only till next MTA restart.


In ZCS 8.0 this configuration worked without a problem. I'm missing something here? Any help would be appreciated.




ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Mon Feb 02, 2015 12:55 pm
by Lukasz Michalik
Anyone?

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Mon Feb 16, 2015 4:36 am
by Zied FAKHFAKH
Same problem here

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Mon Mar 30, 2015 6:01 pm
by fooz
I've encountered the same problem on 8.6.0, quite annoying as my 3rd party anti-spam and several other milters are configured via this mechanism. This worked fine in 8.0.x, but not now.

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Mon Mar 30, 2015 6:14 pm
by fooz

I looked all over at the various provisioning and couldn't figure out why it's not working...


Super-ghetto-but-functional hack is to add a line to the "command()" section of the /etc/init.d/zimbra startup script:


...


        su - zimbra -c "zmcontrol $1 </dev/null"
        su - zimbra -c "postconf -e 'smtpd_milters = inet:127.0.0.1:12322'"
}
...


ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Posted: Tue Apr 07, 2015 2:53 pm
by Lukasz Michalik

Bugzilla issue: https://bugzilla.zimbra.com/show_bug.cgi?id=97706



For now I've found two workarounds.


1. Remove these lines from conf/zmconfigd.cf configuration file, smtpd_milters will not be overwritten.


POSTCONF smtpd_milters


if VAR zimbraMtaSmtpdMilters


    POSTCONF smtpd_milters VAR zimbraMtaSmtpdMilters


fi


2. Set zimbraMtaServerEnabled to TRUE, this will enable build-in milter but will preserve custom milters entries.