All Outgoing Mail Now Held in Deferred Queue

General discussion about Zimbra Desktop.
User avatar
britesc
Posts: 40
Joined: Fri Sep 12, 2014 5:56 am
Location: Spain
ZCS/ZD Version: 8.8.15

All Outgoing Mail Now Held in Deferred Queue

Postby britesc » Sat Feb 20, 2016 5:56 am

I have moved 8.0.6 to a new server with faster CPU more RAM and SSD.


The server also runs Bind 9.


I am now finding that virtually all outbound mail (both internal and external) is held in the Deferred Queue immediately.


If I select Requeue within the GUI Administrator it is immediately sent without problems.


So I am needing to manually requeue the mail on a regular basis.


Can anyone please suggest a fix for this?


Is it that the system is now to fast for the MTA to handle?


Any advice / help gratefully received.


Thanks and kind regards,



jB 



phoenix
Ambassador
Ambassador
Posts: 26576
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

All Outgoing Mail Now Held in Deferred Queue

Postby phoenix » Sat Feb 20, 2016 6:46 am

[quote user="britesc"]Can anyone please suggest a fix for this?[/quote]Not really, you haven't given any information with which anyone can make any guesses as to the cause of the problem.


[quote user="britesc"]Is it that the system is now to fast for the MTA to handle?[/quote]That can't really be a serious comment, can it? ;)


You need to look in the log files to see the reason the email is put in the deferred queue. BTW, you really should upgrade to the current 8.6.x.

Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
Salva_savia
Advanced member
Advanced member
Posts: 50
Joined: Sat Sep 13, 2014 3:26 am

All Outgoing Mail Now Held in Deferred Queue

Postby Salva_savia » Sat Feb 20, 2016 1:31 pm

Hi


We had same problem.


In my case reload amavis and opendkim service in that order


Problem solved.

User avatar
britesc
Posts: 40
Joined: Fri Sep 12, 2014 5:56 am
Location: Spain
ZCS/ZD Version: 8.8.15

All Outgoing Mail Now Held in Deferred Queue

Postby britesc » Tue Feb 23, 2016 10:25 am

Thank you for your reply.

I was pleased after the first reply that someone understood me.

Could you please advise me how to stop amavis and opendkim and then restart them in the order you suggest.



I am on 8.6.0 not 8.0.6 which was a typo as I am partially sighted.



Kind regards,



jB
User avatar
britesc
Posts: 40
Joined: Fri Sep 12, 2014 5:56 am
Location: Spain
ZCS/ZD Version: 8.8.15

All Outgoing Mail Now Held in Deferred Queue

Postby britesc » Tue Feb 23, 2016 10:39 am

Phoenix,



I am sure you are a genius where Zimbra is concerned, but I felt your comments most rude and showing a very immature attitude.

When an obvious newbie is in trouble and posts a cry for help, rather than berating them for typos and comments, it would have been kinder not to have replied at all.



I was in a very senior IT role with an extremely large Fortune 500 company, managing a very large global department, before I had an accident that has left me disabled and partially sighted. If one of my staff had replied to someone as you have done I would have dismissed them on the spot.



Yes, I have experienced a few times where as technology progressed, applications became unstable and unable to operate correctly. Apart from the misspelling of too, the question was quite valid.



I have noticed that you have a tendency to abuse posters within this forum, maybe that is your way of climbing the postings ladder. but I ask you to consider the feelings that others have when they are making requests for help.



Perhaps you could suggest which logs and what to be looking for etc.



Kind regards



jB
User avatar
syslint
Posts: 36
Joined: Wed Feb 24, 2016 7:59 am
Contact:

All Outgoing Mail Now Held in Deferred Queue

Postby syslint » Wed Feb 24, 2016 8:38 am

Dear JB,

Please check the log files /var/log/zimbra.log and /var/log/maillog . I think your bind ( DNS ) messed up. So please use the dig tool to check the dns resolution of your email domain from the server.
24x7 PROACTIVE ZIMBRA SERVER MANAGEMENT | Sales : sales @ syslint.com | Skype us : SyslintSkype | Call us : (+91) 471-60 - 7799 | visit : https://syslint.com
User avatar
britesc
Posts: 40
Joined: Fri Sep 12, 2014 5:56 am
Location: Spain
ZCS/ZD Version: 8.8.15

All Outgoing Mail Now Held in Deferred Queue

Postby britesc » Thu Feb 25, 2016 5:11 am

Thank you for your reply.

I am having a "I hope I know What to Look For" read of the logs, plus mail.err and syslog just to see if I can spot anything obvious.



Dig requests both as root and zimbra both use my Primary DNS Server rather than the Secondary DNS Server configured on the Zimbra Server. So that might be a starting point too.



Kind regards,



jB

PS Everything worked fine on the old server for the couple of years it was in use and I thought I copied everything over correctly. I just love IT.
User avatar
britesc
Posts: 40
Joined: Fri Sep 12, 2014 5:56 am
Location: Spain
ZCS/ZD Version: 8.8.15

All Outgoing Mail Now Held in Deferred Queue

Postby britesc » Sun Feb 28, 2016 4:59 am

I am hoping that the problem is now resolved.


Even though Bind9 is running on the server, it appears that the zimbraDNSMasterIP had been configured, and it was also configured to point to the primary dns rather than the local caching copy.


Since I deleted the entry and made sure no other dns were mentioned, mail does appear to be moving through the system.


So it appears that even when the dns caching daemon is not installed / active the MTA still uses any values set in the configuration file.


Thanks for your help and also [View:https://wiki.zimbra.com/wiki/DNS_caching_service_(dnscache)]


Kind regards,


jB


Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 3 guests