Page 1 of 1

SQL Table Missing

Posted: Tue Sep 01, 2015 8:27 pm
by mhammett

I added an IMAP account to my otherwise Zimbra & GMAIl only Zimbra Desktop today. In a short order afterwards, I was getting errors when sending e-mail. I could receive all new messages, but read status wasn't syncing properly and I couldn't send.



I tried a bunch of things server level thinking the servers were jacked up, but I later discovered that web mail worked fine. I tried resetting the GAL and the index, but still broken, finally I tried resetting accounts. The first one worked. The second account I tried to reset gave me this:


Failure communicating with remote server. Please try again later.
(debug info)
[SQLITE_ERROR] SQL error or missing database (no such table: mboxgroup2.tombstone) Exception:

com.zimbra.common.service.ServiceException: system failure: reading tombstones since change: 0
ExceptionId:sync-mbox-mike.hammett@ics-il.com:1441156482077:9db47833e71ba660
Code:service.FAILURE
at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:253)
at com.zimbra.cs.db.DbMailItem.readTombstones(DbMailItem.java:1901)
at com.zimbra.cs.mailbox.Mailbox.getTombstones(Mailbox.java:2749)
at com.zimbra.cs.mailbox.PushChanges.sync(PushChanges.java:212)
at com.zimbra.cs.mailbox.PushChanges.sync(PushChanges.java:195)
at com.zimbra.cs.mailbox.MailboxSync.sync(MailboxSync.java:193)
at com.zimbra.cs.mailbox.ZcsMailbox.sync(ZcsMailbox.java:124)
at com.zimbra.cs.mailbox.ZcsMailbox.syncOnTimer(ZcsMailbox.java:105)
at com.zimbra.cs.mailbox.SyncMailbox$1.run(SyncMailbox.java:279)
at java.util.TimerThread.mainLoop(Unknown Source)
at java.util.TimerThread.run(Unknown Source)
Caused by: java.sql.SQLException: [SQLITE_ERROR] SQL error or missing database (no such table: mboxgroup2.tombstone)
at org.sqlite.DB.newSQLException(DB.java:383)
at org.sqlite.DB.newSQLException(DB.java:387)
at org.sqlite.DB.throwex(DB.java:374)
at org.sqlite.NativeDB.prepare(Native Method)
at org.sqlite.DB.prepare(DB.java:123)
at org.sqlite.PrepStmt.(PrepStmt.java:42)
at org.sqlite.Conn.prepareStatement(Conn.java:410)
at org.sqlite.Conn.prepareStatement(Conn.java:405)
at org.sqlite.Conn.prepareStatement(Conn.java:389)
at com.zimbra.cs.db.RetryConnection$1.execute(RetryConnection.java:37)
at com.zimbra.cs.db.AbstractRetry.doRetry(AbstractRetry.java:58)
at com.zimbra.cs.db.RetryConnection.prepareStatement(RetryConnection.java:41)
at org.apache.commons.dbcp.DelegatingConnection.prepareStatement(DelegatingConnection.java:281)
at org.apache.commons.dbcp.PoolingDataSource$PoolGuardConnectionWrapper.prepareStatement(PoolingDataSource.java:313)
at com.zimbra.cs.db.DbPool$Connection.prepareStatement(DbPool.java:105)
at com.zimbra.cs.db.DbMailItem.readTombstones(DbMailItem.java:1877)
... 9 more

If issue persists please post description and debug information here.




Is everything just fscked?