ZD 7.3 not working on CentOS 6 or 7

If Zimbra Desktop had a sync failure, it may have told you to post your error in this section.
Posts: 29
Joined: Fri Sep 12, 2014 11:16 pm

ZD 7.3 not working on CentOS 6 or 7

Postby jaapaikema » Thu May 04, 2017 7:37 am

I tried updating my ZD 7.2.8 when notified there was a ZD 7.3.
The upgrade failed so I downloaded the install-file and tried installing ZD 7.3.
Installing as root went fine.
Creating user-environment went fine.

Code: Select all

[someone@host]$ /opt/zimbra/zdesktop/linux/user-install.pl
Choose the folder where you would like to install Zimbra Desktop's user data files, full path please [/home/someone/zdesktop]:

Choose the folder where you would like to create desktop icon [/home/someone/Desktop]:

Installing user data files...done
Initializing user data...done
Creating desktop icon...done
Zimbra Desktop has been installed successfully for user someone.

You can start Zimbra Desktop by double-clicking the desktop icon or by running the following command:

Press "Enter" to launch Zimbra Desktop; Press "Ctrl-c" to exit:

Starting Jetty went fine.
Starting NW didn't go well.

When I ran /opt/zimbra/zdesktop/linux/zdrun.pl from a terminal this is the response:

Code: Select all

[someone@host]$ /opt/zimbra/zdesktop/linux/zdrun.pl
JRE version 7 is found on your system.
JETTY_HOME     =  /opt/zimbra/zdesktop/jetty
JETTY_RUN      =  /home/someone/zdesktop/log
JETTY_PID      =  /home/someone/zdesktop/log/zdesktop.pid
JETTY_CONSOLE  =  /home/someone/zdesktop/log/zdesktop.out
CONFIGS        =  /home/someone/zdesktop/jetty/etc/jetty.xml
JAVA_OPTIONS   =  -client -Djava.awt.headless=true -Xms128m -Xmx1024m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -XX:NewRatio=4 -XX:TargetSurvivorRatio=70 -XX:+UseConcMarkSweepGC -DSTART='/opt/zimbra/zdesktop/jetty/etc/start.config' -Dzimbra.home='/home/someone/zdesktop' -Dzimbra.config='/home/someone/zdesktop/conf/localconfig.xml' -Djava.library.path='/opt/zimbra/zdesktop/jetty/../lib' -Djava.awt.headless=true -Djava.io.tmpdir='/home/someone/zdesktop/data/tmp/java' -Djava.net.useSystemProxies=true -Dsun.net.inetaddr.ttl=10 -XX:HeapDumpPath='/home/someone/zdesktop/heapdump/' -XX:+HeapDumpOnOutOfMemoryError -Djetty.home='/opt/zimbra/zdesktop/jetty'
JAVA           =  /usr/lib/jvm/jre-1.7.0-openjdk/bin/java
Starting Jetty:
Stale pid file removed: /home/someone/zdesktop/log/zdesktop.pid
Jetty running pid=1287
nohup: redirecting stderr to stdout
/opt/zimbra/zdesktop/linux/node-webkit/zdesktop: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/zimbra/zdesktop/linux/node-webkit/lib/libnw.so)
/opt/zimbra/zdesktop/linux/node-webkit/zdesktop: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by /opt/zimbra/zdesktop/linux/node-webkit/lib/libnw.so)
/opt/zimbra/zdesktop/linux/node-webkit/zdesktop: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /opt/zimbra/zdesktop/linux/node-webkit/lib/libnw.so)

I thought it might be that I forgot to install libstdc++, but when I queried the rpm-database this was the result:

Code: Select all

[someone@host]$ rpm -qa |grep libstdc++

Any one have a thought on how to resolve this problem?

Return to “Error Reports”

Who is online

Users browsing this forum: No registered users and 2 guests