Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Need some help getting Zimbra Desktop set up and working?
User avatar
jorgedlcruz
Zimbra Employee
Zimbra Employee
Posts: 2696
Joined: Thu May 22, 2014 4:47 pm

Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby jorgedlcruz » Fri Jun 19, 2015 8:16 am

Hi guys,


We have worked in the steps to make it work Zimbra Desktop in Ubuntu Desktop 64 bits, as many of you was asking about it, and all the recent Desktop versions are based in Linux are 64 bits.


Take a look into the next Wiki and follow the steps to have Zimbra Desktop, 7.2.7 Beta in this case, working in your Ubuntu Desktop 64 bits.



You can see here an example of the latest Ubuntu 15.04 Desktop 64 bits and Zimbra Desktop 7.2.7 Beta, working together.



Let us know your feedback.



Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
Harpowned
Posts: 1
Joined: Fri Oct 16, 2015 7:11 am

Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby Harpowned » Fri Oct 16, 2015 7:43 am

Hello,



The solution proposed on the wiki involves changing the default java virtual machine for the whole system to the 32-bit one.



This change, while it does solve the Zimbra Desktop problem, also affects any other java programs running on the machine, which will now also use the 32-bit java vm. This breaks some other software, which (very much like Zimbra Desktop) requires a specific java vm architecture to work.



My suggestion is that you only change the java vm used by Zimbra Desktop, and keep the 64-bit one as a system-wide default.

To do this, follow the guide up to step 5 (install the required packages), but don't do step 6 (update-alternatives).

Instead, edit the Zimbra Desktop launch script, which is in /opt/zimbra/zdesktop/data/bin/zdesktop, but it is also copied to each of the user's home, at /home/${USER}/zdesktop/bin/zdesktop



You want to change line 214, from this:

JAVA=`which java`

to this:

JAVA="/usr/lib/jvm/java-7-openjdk-i386/jre/bin/java"



This will cause Zimbra Desktop to use the 32-bit java vm, while keeping the 64-bit one as system-wide default.
jotrago
Posts: 1
Joined: Sun Jan 03, 2016 8:18 am
Location: Cape Town
ZCS/ZD Version: ZCO 8.6.0.1320
Contact:

Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby jotrago » Sun Jan 03, 2016 8:45 am

Been struggling for 3 days to get  ZD 7_2_7_ga_b12059_linux_i686 to install on Linux Mint 17.3 Clean install in a VBox VM running an Linux Mint 17.3 Host


A few weeks ago I successfully installed in Mint 17.1 so I was rather shocked that it didn't work this time round


Having followed your installation howto above and using the Java pointer in both system and user run scripts I get :-


=============================================================================


johng@Mint17-3Dev ~ $ "/opt/zimbra/zdesktop/linux/prism/zdclient" -webapp "/home/johng/AppsData/ZimbraDesktop/zdesktop.webapp" -override "/home/johng/AppsData/ZimbraDesktop/zdesktop.webapp/override.ini" -profile "/home/johng/AppsData/ZimbraDesktop/profile"


(process:4492): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed


LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-cone-plugin.so [/usr/lib/mozilla/plugins/libtotem-cone-plugin.so: wrong ELF class: ELFCLASS64]


LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so [/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: wrong ELF class: ELFCLASS64]


LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-mully-plugin.so [/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: wrong ELF class: ELFCLASS64]


LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so [/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: wrong ELF class: ELFCLASS64]


LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so [/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so: wrong ELF class: ELFCLASS64]


LoadPlugin: failed to initialize shared library /usr/lib/adobe-flashplugin/libflashplayer.so [/usr/lib/adobe-flashplugin/libflashplayer.so: wrong ELF class: ELFCLASS64]


Usage: java [-options] class [args...]


          (to execute a class)


  or  java [-options] -jar jarfile [args...]


          (to execute a jar file)


where options include:


   -d32  use a 32-bit data model if available


   -d64  use a 64-bit data model if available


   -client  to select the "client" VM


   -server  to select the "server" VM


   -zero  to select the "zero" VM


   -jamvm  to select the "jamvm" VM


   -avian  to select the "avian" VM


   -dcevm  to select the "dcevm" VM


   -hotspot  is a synonym for the "client" VM  [deprecated]


                 The default VM is server,


                 because you are running on a server-class machine.


   -cp <class search path of directories and zip/jar files>


   -classpath <class search path of directories and zip/jar files>


                 A : separated list of directories, JAR archives,


                 and ZIP archives to search for class files.


   -D<name>=<value>


                 set a system property


   -verbose:[class|gc|jni]


                 enable verbose output


   -version      print product version and exit


   -version:<value>


                 require the specified version to run


   -showversion  print product version and continue


   -jre-restrict-search | -no-jre-restrict-search


                 include/exclude user private JREs in the version search


   -? -help      print this help message


   -X            print help on non-standard options


   -ea[:<packagename>...|:<classname>]


   -enableassertions[:<packagename>...|:<classname>]


                 enable assertions with specified granularity


   -da[:<packagename>...|:<classname>]


   -disableassertions[:<packagename>...|:<classname>]


                 disable assertions with specified granularity


   -esa | -enablesystemassertions


                 enable system assertions


   -dsa | -disablesystemassertions


                 disable system assertions


   -agentlib:<libname>[=<options>]


                 load native agent library <libname>, e.g. -agentlib:hprof


                 see also, -agentlib:jdwp=help and -agentlib:hprof=help


   -agentpath:<pathname>[=<options>]


                 load native agent library by full pathname


   -javaagent:<jarpath>[=<options>]


                 load Java programming language agent, see java.lang.instrument


   -splash:<imagepath>


                 show splash screen with specified image


See [View:http://www.oracle.com/technetwork/java/javase/documentation/index.html:0:0] for more details.


JRE is not found on your system.


AND


A window opens with rotating indicator then a  dialog appears with


"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.


Script: file:///opt/zimbra/zdesktop/linux/prism/modules/WebAppProperties.jsm:213"


Both the window and the dialog disappear after a minute or so.


==================================================================================


At this point it looks to me like there are several issues.


1.  Some other part of the system is making a call to the default JVM and failing.  


2. It appears that we may need some more :i386 modules


    icedtea   I tried installing icedtea-7-plugin:i386, which tried to load icedtea-netx:i386 but that failed, apparently also trying to call the default JVM


I could set the default JVM as per the original HowTo to test that.


I also had a couple of stumbling blocks during the setup and install process :-


1. From the various posts I tested the presence of the following libs. Those marked OK were already present, The others I installed successfuly, and the re-installation of the gtk2-engines-murrine:i386 went OK


libxt6:i386  ok


libc6:i386  ok


libgcc1:i386  ok


gcc-4.6-base:i386 install


libstdc++5:i386 ok


libasound2:i386 ok


libgtk2.0-0:i386 ok


libxtst6:i386 ok


Also mentioned


libnss3-1d:i386 install


libnspr4-0d:i386  install


lib32nss-mdns


The following extra packages will be installed:


 libnss-mdns:i386 libnss-mdns-i386:i386


libxml2:i386  ok


libxslt1.1:i386 ok


2. Installing the openjdk-7-jre:i386


   I got this error


Unpacking openjdk-7-jre:i386 (7u91-2.6.3-0ubuntu0.14.04.1) ...


dpkg: error processing archive /var/cache/apt/archives/openjdk-7-jre_7u91-2.6.3-0ubuntu0.14.04.1_i386.deb (--unpack):


trying to overwrite shared '/usr/share/applications/openjdk-7-policytool.desktop', which is different from other instances of package openjdk-7-jre:i386


dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)



Renaming the file and rerunning the install fixed that. My guess is that the existing file is newer than the one being installed.




Any feedback or advice would be greatly appreciated.



Best regards


JoTraGo

BradC
Posts: 12
Joined: Tue May 03, 2016 1:39 am

Re: Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby BradC » Tue May 03, 2016 2:09 am

Harpowned wrote:The solution proposed on the wiki involves changing the default java virtual machine for the whole system to the 32-bit one.

This change, while it does solve the Zimbra Desktop problem, also affects any other java programs running on the machine, which will now also use the 32-bit java vm. This breaks some other software, which (very much like Zimbra Desktop) requires a specific java vm architecture to work.


I was floored when I saw that recommendation and I have nothing nice to say about it.

Harpowned wrote:Instead, edit the Zimbra Desktop launch script, which is in /opt/zimbra/zdesktop/data/bin/zdesktop, but it is also copied to each of the user's home, at /home/${USER}/zdesktop/bin/zdesktop


Just a +1 for this. It would be so easy to modify the default zdesktop file NOT to overwrite the JAVA variable if it is already set allowing us to pre-set that variable in whatever we use to launch zdesktop. In any case, editing the zdesktop file is no big task and can be edited in the app/data/bin directory of the installer tarball so as to deploy properly when doing multiple installs.

I'm showing my ignorance here, but java being java where it's supposed to be "compile once, run anywhere", I don't understand why stuff that runs on a 32bit jre won't run on a 64bit jre. It seems to work fine with all my other Java applications.
PriteshGajjar
Zimbra Employee
Zimbra Employee
Posts: 310
Joined: Tue Mar 31, 2015 4:59 am

Re: Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby PriteshGajjar » Tue May 10, 2016 2:36 pm

We should not have to deal with all these workaround once we have 64-bit ZD for Linux.
https://bugzilla.zimbra.com/show_bug.cgi?id=65456 - This is already identified as priority item for next release 7.3.
hopscu
Posts: 1
Joined: Fri Jun 03, 2016 11:02 pm

Re: Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby hopscu » Fri Jun 03, 2016 11:29 pm

Are people installing zdesktop in Mint? I installed ia32-libs from the repository, but that did not help. Then I saw the Ubuntu article. Will it work for Mint, and should I uninstall ZD to start over, or just install lib files and jre version?

Will the 64-to-32-bit workaround still break other apps?
llewellen
Posts: 5
Joined: Tue Oct 11, 2016 6:11 pm

Re: Installing Zimbra Desktop 7 on Ubuntu Desktop 64bits

Postby llewellen » Tue Oct 11, 2016 7:55 pm

I tried this. It doesn't work, as confirmed in bugzilla.zimbra.com and by me.

Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 4 guests