Installation Fail Under User Account

Need some help getting Zimbra Desktop set up and working?
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Installation Fail Under User Account

Postby rolo » Mon Jun 19, 2017 3:04 pm

Zimbra Desktop 7.3 64-Bit Install on Ubuntu 16.04 Desktop 64-Bit

Install worked fine until attempting to install under user's profile. Error is as follows:

Initializing user data...Error: cannot open file /opt/zimbra/zdesktop/linux/zdrun.pl.tmp

Any help on this would be appreciated.

Thanks,
Rob


User avatar
DualBoot
Outstanding Member
Outstanding Member
Posts: 663
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Installation Fail Under User Account

Postby DualBoot » Mon Jun 19, 2017 3:28 pm

You should run the installer under root user.
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Re: Installation Fail Under User Account

Postby rolo » Mon Jun 19, 2017 3:40 pm

Thanks for the reply. I thought maybe that would be the case but I am not trying to install this under an admin account nor am I trying to install it as the root user.

This is the install for the standard user...not for the root user. The user is not an admin, and therefore (as far as I know) cannot have the user zimbra account install completed as root. I have done the install before successfully which is why this scenario is odd.

Also, this is the first attempt on installing it on a 64-bit linux system. Not sure if those things are linked or not but figured I would mention it regardless.
User avatar
DualBoot
Outstanding Member
Outstanding Member
Posts: 663
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Installation Fail Under User Account

Postby DualBoot » Mon Jun 19, 2017 3:49 pm

As far I can remember, the installer ask for the folder place where to install user data.
Was it the case ?
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Re: Installation Fail Under User Account

Postby rolo » Mon Jun 19, 2017 3:55 pm

Correct,

First step is the root install and the default after that install completes is to NOT install to the root folder. I will post the results below:

Code: Select all

sudo ./install.pl

Code: Select all

Welcome to Zimbra Desktop setup wizard. This will install Zimbra Desktop on your computer.
------------------------------
Press enter to continue:

PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE. ZIMBRA WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

Code: Select all

------------------------------
Choose the folder where you would like to install Zimbra Desktop's application files [/opt/zimbra/zdesktop]:

Installing application files...done

You have finished installing application files.

Would you like to continue to install data files for user: root ?
------------------------------
(Y)es or (N)o [N]: n

To install data files for additional users, please login as the user and run this command:
/opt/zimbra/zdesktop/linux/user-install.pl


Once that completes successfully, I log into the user profile and attempt the user install script "/opt/zimbra/zdesktop/linux/user-install.pl"
which results in the error I originally posted.
User avatar
DualBoot
Outstanding Member
Outstanding Member
Posts: 663
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Installation Fail Under User Account

Postby DualBoot » Mon Jun 19, 2017 3:58 pm

run this command as root.
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Re: Installation Fail Under User Account

Postby rolo » Mon Jun 19, 2017 4:02 pm

The only way I can run that command as root would be to change the standard user to an administrator and then run it as root which wouldn't make any sense because historically this was never required. If that is the case now, then there is an error in the installer. Root shouldn't be required for standard install of the user profile.

I will try though, I guess at this point it can't hurt lol :)
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Re: Installation Fail Under User Account

Postby rolo » Mon Jun 19, 2017 4:32 pm

Installed under the user profile as root. Install successfully completed but when running the software it will not launch. Expected since it is installed as root but run as a standard user.

Something isn't right...Any other suggestions or ideas?

Thanks
User avatar
DualBoot
Outstanding Member
Outstanding Member
Posts: 663
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Installation Fail Under User Account

Postby DualBoot » Mon Jun 19, 2017 8:05 pm

Launch this application with a terminal to know what is going wrong.
rolo
Posts: 11
Joined: Wed Oct 26, 2016 4:40 pm

Re: Installation Fail Under User Account

Postby rolo » Wed Jun 21, 2017 4:01 pm

OK - I have started from scratch, new install, no updates, etc. I even went back to the Install docs for 7.3 in the odd chance something changed over the past years of doing this installation.

Same issue as earlier. Initial install under root goes fine, switch to standard user profile, run the /opt/zimbra/zdesktop/linux/user-install.pl script and get the same error, "Initializing user data...Error: cannot open file /opt/zimbra/zdesktop/linux/zdrun.pl.tmp". I have even tried changing permissions on the /opt/zimbra/zdesktop folder, which allows the install to succeed but then bricks the software when trying to run.

Someone please let me know if this issue is occurring to someone else, or if they know what is going on and how to go about fixing it. I guess I could install a earlier build and go through the whole 32-bit hack to get it to work but I would really like to just figure out what is going on with the 7.3 install package.

Thanks,
Rob

Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 3 guests